天天看點

1088. Rational Arithmetic (20)

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format "a1/b1 a2/b2". The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is "number1 operator number2 = result". Notice that all the rational numbers must be in their simplest form "k a/b", where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output "Inf" as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2
      

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)
      

Sample Input 2:

5/3 0/6
      

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf      
#include <iostream>
#include <string>
#include <sstream>
using namespace std;

long gcd(long a, long b){
    while(a){
        long t = a;
        a = b % a;
        b = t;
    }
    return b;
}

string func(long a, long b){
    if(a == 0) return "0";
    long t = gcd(a, b);
    a = a / t;
    b = b / t;
    string s;
    stringstream ss;
    int flag = 0;
    if(a < 0 && b < 0) {a = -a; b = -b;}
    if(a < 0 && b > 0) {flag = 1; a = -a;}
    if(a > 0 && b < 0) {flag = 1; b = -b;}
    if(flag) ss << "(-";
    
    if (a / b && a % b) {
        ss << a / b << ' ' << a % b << '/' << b;
    }else if(a / b){
        ss << a / b;
    }else{
        ss << a << '/' << b;
    }
    if(flag) ss << ")";
    getline(ss, s);
    
    return s;
}

int main(){
    long a1, b1, a2, b2;
    scanf("%ld/%ld %ld/%ld", &a1, &b1, &a2, &b2);

    long t1 = a1 * b2 + a2 * b1;
    long t2 = b1 * b2;
    string s1 = func(a1, b1);
    string s2 = func(a2, b2);
    cout << s1 << " + " << s2 << " = " << func(t1, t2) << endl;
    t1 = a1 * b2 - a2 * b1;
    cout << s1 << " - " << s2 << " = " << func(t1, t2) << endl;
    t1 = a1 * a2;
    t2 = b1 * b2;
    cout << s1 << " * " << s2 << " = " << func(t1, t2) << endl;
    cout << s1 << " / " << s2 << " = ";
    if(a2 == 0) cout << "Inf" << endl;
    else{
        t1 = a1 * b2;
        t2 = b1 * a2;
        cout << func(t1, t2) << endl;
    }
    
    return 0;
}
           

繼續閱讀