天天看點

ip ospf database-filter all out

From: "Brian McGahan" <brian@xxxxxxxxxxxxxxx>
To: "'Robert Massiache'" <robert2140@xxxxxxxxxxx>, <ccielab@xxxxxxxxxxxxxx>
Subject: RE: No LSA Command
Date: Sun, 20 Oct 2002 10:27:40 -0500      
Robert,
The command "ip ospf database-filter all out" works like passive
interface does in distance vector protocols.  When you say 'passive
interface' in OSPF, you deny sending any hello packets out an interface,
therefore an adjacency cannot be established.  With 'ip ospf
database-filter' on the other hand, you are only filtering the LSA
generation.  This means that you can still establish adjacencies (since
hellos are still sent), but you won't send your neighboring router any
LSA's.  Therefore you will receive all the LSA's in their database, but
they will not receive any of yours.  Observe the following:      
R1--12.0.0.0/8--R2
R1 and R2 share an Ethernet segment running OSPF.  They each
advertise a prefix into the OSPF domain, 1.1.1.1/32 and 2.2.2.2/32
respectively.  R2 uses the command 'ip ospf database-filter all out' on
the Ethernet segment between them.  Therefore, R1 does not receive the
LSA 2.2.2.2/32 in its OSPF database (and therefore the IP routing
table), yet R2 still does receive the LSA 1.1.1.1/32 and installs it in
the IP routing table.      
R1#sh ip int brief
Interface          IP-Address      OK? Method Status
Protocol
FastEthernet0/0    12.0.0.1        YES manual up                    up      
Loopback0          1.1.1.1         YES manual up                    up
!
R1#sh run | b router ospf
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!
R1#sh ip ospf nei
Neighbor ID    Pri   State           Dead Time   Address
Interface
2.2.2.2          1   FULL/DR         00:00:35    12.0.0.2
FastEthernet0/0
!      
R2#sh ip int brief
Interface          IP-Address      OK? Method Status
Protocol
Ethernet0          12.0.0.2        YES manual up                    up      
Loopback0 2.2.2.2 YES manual up up
!
R2#sh run int e0
interface Ethernet0
 ip address 12.0.0.2 255.0.0.0
 ip ospf database-filter all out
end
!
R2#sh run | b router ospf
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!
R2#sh ip ospf nei
Neighbor ID     Pri   State           Dead Time   Address
Interface
1.1.1.1           1   FULL/BDR        00:00:37    12.0.0.1
Ethernet0
!      
R2#sh ip route
<snip>
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/11] via 12.0.0.1, 00:05:43, Ethernet0
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
C    12.0.0.0/8 is directly connected, Ethernet0
!
R1#sh ip route
<snip>
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
C    12.0.0.0/8 is directly connected, FastEthernet0/0
R1#
!
R1#sh ip ospf dat      

OSPF Router with ID (1.1.1.1) (Process ID 1)

Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link
count
1.1.1.1         1.1.1.1         475         0x80000005 0x7B7B   2
!
R2#sh ip ospf dat      
OSPF Router with ID (2.2.2.2) (Process ID 1)
Link ID         ADV Router      Age         Seq#       Checksum Link
count
1.1.1.1         1.1.1.1         480         0x80000005 0x7B7B   2
2.2.2.2         2.2.2.2         486         0x80000006 0x27B8   2      
Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
12.0.0.2        2.2.2.2         488         0x80000001 0x29EE
!      
HTH
Brian McGahan, CCIE #8593
Director of Design and Implementation
brian@xxxxxxxxxxxxxxx      
CyscoExpert Corporation
Internetwork Consulting & Training
Voice: 847.674.3392
Fax: 847.674.2625      
原文位址 [url]http://www.groupstudy.com/archives/ccielab/200210/msg01831.html[/url]

繼續閱讀