天天看點

ZOJ - 3640 Help Me Escape

Background

    If thou doest well, shalt thou not be accepted? and if thou doest not well, sin lieth at the door. And unto thee shall be his desire, and thou shalt rule over him. 

    And Cain talked with Abel his brother: and it came to pass, when they were in the field, that Cain rose up against Abel his brother, and slew him. 

    And the LORD said unto Cain, Where is Abel thy brother? And he said, I know not: Am I my brother's keeper? 

    And he said, What hast thou done? the voice of thy brother's blood crieth unto me from the ground. 

    And now art thou cursed from the earth, which hath opened her mouth to receive thy brother's blood from thy hand; 

    When thou tillest the ground, it shall not henceforth yield unto thee her strength; a fugitive and a vagabond shalt thou be in the earth.

—— Bible Chapter 4

Now Cain is unexpectedly trapped in a cave with N paths. Due to LORD's punishment, all the paths are zigzag and dangerous. The difficulty of the ith path is ci.

Then we define f as the fighting capacity of Cain. Every day, Cain will be sent to one of the N paths randomly.

Suppose Cain is in front of the ith path. He can successfully take ti days to escape from the cave as long as his fighting capacity f is larger than ci. Otherwise, he has to keep trying day after day. However, if Cain failed to escape, his fighting capacity would increase ci as the result of actual combat. (A kindly reminder: Cain will never died.)

As for ti, we can easily draw a conclusion that ti is closely related to ci. Let's use the following function to describe their relationship:

ZOJ - 3640 Help Me Escape

After D days, Cain finally escapes from the cave. Please output the expectation of D.

Input

The input consists of several cases. In each case, two positive integers N and f (n≤ 100, f ≤ 10000) are given in the first line. The second line includes N positive integers ci (ci ≤ 10000, 1 ≤ i ≤ N)

Output

For each case, you should output the expectation(3 digits after the decimal point).

Sample Input

3 1
1 2 3
      

Sample Output

6.889      

大緻就是有一個人要逃出i個洞穴,當戰鬥力f超過ci時,花費ti天能逃出這個洞口,不然就花一天時間提升si點戰鬥力,求逃出去的天數期望。

這題我做的迷迷糊糊的,雖然說知道求期望要逆推,但是這道題也不是很簡單的從n逆推到1。

設dp[f]是戰鬥力為f時逃出去的天數期望,那麼dp(i) = ( dp(i+c1) + dp(i+c2) + ... + dp(i+cn) ) / n;這是為啥呢?我也不是最清楚,大概是把過每個山洞的期望加起來總和除以n就是最後的期望……為啥呢。

#include <bits/stdc++.h>

using namespace std;

const int maxn=2e4+10;

double dp[maxn];
double c[maxn];
double p=0.5+sqrt(5.0)/2;
int n,f;
double dfs(int tf)
{
    if(dp[tf]>0)
        return dp[tf];
    for(int i=0;i<n;i++)
        if(tf>c[i])
            dp[tf]+=floor(p*c[i]*c[i])/n;
        else
            dp[tf]+=(dfs(tf+c[i])+1)/n;
    return dp[tf];
}
int main()
{
    while(cin>>n>>f)
    {
        for(int i=0;i<n;i++)
            cin>>c[i];
        memset(dp,0,sizeof(dp));
        printf("%.3f\n",dfs(f));
    }
    return 0;
}