天天看點

poj2923(狀态壓縮+01背包)

位址:http://poj.org/problem?id=2923

Relocation

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1667 Accepted: 679

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers n, C1 and C2. C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98      

Sample Output

Scenario #1:
2

Scenario #2:
3      

題意:A君和B君要搬家,他們叫了2輛車來搬n件家具,家具的重量和車的承重已給出。問最少要幾趟才能搬完家。

思路:因為最多隻有10件家具,是以用狀态壓縮。将家具分别組合起來,找出可以搬運的組合,求搬運不重複組合的最小值。

代碼:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define MA 0xfffffff
int n,v1,v2,vol[20],dp[1050],val[1050];
int yasuo(int s)
{
    int i=1,j,sum=0,vis[1050];
    memset(vis,0,sizeof(vis));
    vis[0]=1;
    while(s)
    {
        if(1&s)
        {
            sum+=vol[i];
            for(j=v1;j>=vol[i];j--)
                if(vis[j-vol[i]]) vis[j]=1;
        }
        s=s>>1;i++;
    }
    for(i=0;i<=v1;i++)
        if(vis[i]&&sum-i<=v2)  //這裡是一個重點:這個判斷将兩輛車和為一輛來看。
            return 1;
    return 0;
}
int main()
{
    int t,cas=1,i,j,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&v1,&v2);
        for(i=1;i<=n;i++) scanf("%d",&vol[i]);
        m=0;
        for(i=1;i<(1<<n);i++)
        {
            if(yasuo(i))
                val[m++]=i;  //另開一個數組來儲存可運送的組合。
            dp[i]=MA;
        }dp[0]=0;
        for(i=0;i<m;i++)
        {
            for(j=(1<<n)-1;j>=0;j--)
            {
                if(dp[j]==MA) continue;
                if((j+val[i])==(j|val[i]))  //這裡是判斷已運送的家具和要運送的家具是否重複。
                {
                    dp[j+val[i]]=min(dp[j]+1,dp[j+val[i]]);  //這裡注意:因為是最小值,是以用min;又因為是求容量和,是以前面是j+val[i]。
                }
            }
        }
        printf("Scenario #%d:\n%d\n\n",cas++,dp[(1<<n)-1]);
    }
    return 0;
}