天天看點

UVA 1291 - Dance Dance Revolution(dp)

Mr. White, a fat man, now is crazy about a game named ``Dance, Dance, Revolution". But his dance skill is so poor that he could not dance a dance, even if he dances arduously every time. Does ``DDR" just mean him a perfect method to squander his pounds? No way. He still expects that he will be regarded as ``Terpsichorean White" one day. So he is considering writing a program to plan the movement sequence of his feet, so that he may save his strength on dancing. Now he looks forward to dancing easily instead of sweatily.

``DDR" is a dancing game that requires the dancer to use his feet to tread on the points according to the direction sequence in the game. There are one central point and four side points in the game. Those side points are classified as top, left, bottom and right. For the sake of explanation, we mark them integers. That is, the central point is 0, the top is 1, the left is 2, the bottom is 3, and the right is 4, as the figure below shows:

UVA 1291 - Dance Dance Revolution(dp)

At the beginning the dancer's two feet stay on the central point. According to the direction sequence, the dancer has to move one of his feet to the special points. For example, if the sequence requires him to move to the top point at first, he may move either of his feet from point 0 to point 1 (Note: Not both of his feet). Also, if the sequence then requires him to move to the bottom point, he may move either of his feet to point 3, regardless whether to use the foot that stays on point 0 or the one that stays on point 1.

There is a strange rule in the game: moving both of his feet to the same point is not allowed. For instance, if the sequence requires the dancer to the bottom point and one of his feet already sta ys on point 3, he should stay the very foot on the same point and tread again, instead of moving the other one to point 3.

After dancing for a long time, Mr. White can calculate how much strength will be consumed when he moves from one point to another. Moving one of his feet from the central point to any side points will consume 2 units of his strength. Moving from one side point to another adjacent side point will consume 3 units, such as from the top point to the left point. Moving from one side point to the opposite side point will consume 4 units, such as from the top point to the bottom point. Yet, if he stays on the same point and tread again, he will use 1 unit.

Assume that the sequence requires Mr. White to move to point 1 

UVA 1291 - Dance Dance Revolution(dp)

 2 

UVA 1291 - Dance Dance Revolution(dp)

 2 

UVA 1291 - Dance Dance Revolution(dp)

 4. His feet may stays on (point 0, point 0) 

UVA 1291 - Dance Dance Revolution(dp)

 (0, 1) 

UVA 1291 - Dance Dance Revolution(dp)

 (2, 1) 

UVA 1291 - Dance Dance Revolution(dp)

 (2, 1) 

UVA 1291 - Dance Dance Revolution(dp)

 (2, 4). In this couple of integers, the former number represents the point of his left foot, and the latter represents the point of his right foot. In this way, he has to consume 8 units of his strength. If he tries another pas, he will have to consume much more strength. The 8 units of strength is the least cost.

Input 

The input file will consist of a series of direction sequences. Each direction sequence contains a sequence of numbers. Ea ch number should either be 1, 2, 3, or 4, and each represents one of the four directions. A value of 0 in the direction sequence indicates the end of direction sequence. And this value should be excluded from the direction sequence. The input file ends if the sequence contains a single 0.

Output 

For each direction sequence, print the least units of strength will be consumed. The result should be a single integer on a line by itself. Any more white spaces or blank lines are not allowable.

Sample Input 

1 2 2 4 0 
1 2 3 4 1 2 3 3 4 2 0 
0
      

Sample Output 

8 
22      

題意:題意轉自:http://blog.csdn.net/shuangde800/article/details/9876957

UVA 1291 - Dance Dance Revolution(dp)

如上圖,這是一個跳舞機,初始狀态兩個腳都在0,  狀态表示為(0, 0), 然後跳舞機會給你一系列舞步方向,例如2,3,4,2,3.......

每次你必須選擇一隻腳移動到對應數字方向的各格子上。

例如從初始狀态(0,0),要移到1, 可以選擇左腳或者右腳移上去,對應的狀态為(1, 0), (0,1)

有一個限制,除了初始狀态可以是(0, 0),之後的兩隻腳就不能再同時在一個格子上!

移動腳要耗費體力, 從0移動到其它各自都是耗費2, 從1,2,3,4之間,如果是移動到相鄰的格子,比如1->2, 1->4, 3->2, 4->3,耗費體力3

如果是移動到對面的格子,比如1->3, 2->4,耗費體力4。

如果某一步,停止不動,耗費體力1,現在給一串方向,問最少用多少體力可以完成這些動作?

思路:dp,先預處理出cost數組,dp[i][j][k]表示第i步,左腳放j右腳放k時候的最小耗費,dp[i][j][k] = min(dp[i - 1][l][k] + cost[l][j], dp[i - 1][j][r] + cost[k][r]);

注意判斷左腳右腳放在一起的情況。

代碼:

#include <stdio.h>
#include <string.h>
#define INF 0x3f3f3f3f
#define min(a,b) ((a)<(b)?(a):(b))
#define max(a,b) ((a)>(b)?(a):(b))
const int N = 1005;
int cost[5][5], num[N], dp[N][5][5], n;

void init() {
	cost[1][1] = cost[2][2] = cost[3][3] = cost[4][4] = 1;
	cost[0][1] = cost[0][2] = cost[0][3] = cost[0][4] = 2;
	cost[1][2] = cost[2][1] = cost[1][4] = cost[4][1] = cost[2][3] = cost[3][2] = cost[3][4] = cost[4][3] = 3;
	cost[1][3] = cost[3][1] = cost[2][4] = cost[4][2] = 4;
}

int solve() {
	int ans = INF;
	memset(dp, INF, sizeof(dp));
	dp[0][0][0] = 0;
	for (int i = 1; i <= n; i++) {
		for (int j = 0; j <= 4; j++) {
			for (int k = 0; k <= 4; k++) {
				if (j == k) continue;
				if (j == num[i]) {
					for (int l = 0; l <= 4; l++) {
						if (l == k && l != 0) continue;
						dp[i][j][k] = min(dp[i][j][k], dp[i - 1][l][k] + cost[l][j]);
					}
				}
				if (k == num[i]) {
					for (int r = 0; r <= 4; r++) {
						if (r == j && r != 0) continue;
						dp[i][j][k] = min(dp[i][j][k], dp[i - 1][j][r] + cost[r][k]);
					}
				}
				if (i == n)
					ans = min(ans, dp[i][j][k]);
			}
		}
	}
	return ans;
}

int main() {
	init();
	while (~scanf("%d", &num[1]) && num[1]) {
		n = 1;
		while (~scanf("%d", &num[++n]) && num[n]);
		printf("%d\n", solve());
	}
	return 0;
}
           

繼續閱讀