天天看點

Oulipo HDU - 1686(哈希或KMP)比對字元串

題意:字元串比對:尋找字元串S中,字元串T出現的次數

思路:KMP或哈希

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: 

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais… 

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces. 

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap. 

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format: 

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W). 

One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T. 

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
           

Sample Output

1
3
0
           

代碼:KMP

/*next數組的含義就是一個固定字元串的最長字首和最長字尾相同的長度。
ABCEFGHRHHABC
          ABCEFGHRHHABC
末尾(ABC)能跟開頭(ABC)重合的最大長度就是字首和子綴的最大公共長度*/
#include<stdio.h>
#include<string.h>
using namespace std;
int n,a,b,dp[10010];
char u[10010],v[1000010];
void ne()//**注意最長字首:是說以第一個字元開始,但是不包含最後一個字元。*/
{
    int i=0,j=-1;
    dp[0]=-1;//next[0]初始化為-1,-1表示不存在相同的最大字首和最大字尾
    while(i<a)
    {
        if(j==-1||u[i]==u[j]) dp[++i]=++j;//這個是把算的k的值(就是相同的最大字首和最大字尾長)賦給next[q]
        else j=dp[j];//如果下一個不同,那麼k就變成next[k],注意next[k]是小于k的,無論k取任何值。
    }//往前回溯
}
void KMP()
{
    int ans=0;
    int i=0,j=0;
    while(i<a&&j<b)
    {
        if(i==-1||u[i]==v[j])
            j++,i++;
        else i=dp[i];
        if(i==a)
        {
            ans++;
            i=dp[i];
        }
    }
    printf("%d\n",ans);
}
int main()
{
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s%s",u,v);
        a=strlen(u);
        b=strlen(v);
        ne();
        KMP();
    }
    return 0;
}
           

哈希

#include<stdio.h>/*哈希*/
#include<string.h>
#include<algorithm>
using namespace std;
typedef unsigned long long ull;
const int M=1e4+10;
const int p=13331;/*哈希的基數*/
int t,a,b;
char u[M],v[100*M];
ull dp[M];
ull h[M*100];
ull k;
void init()
{
    dp[0]=1;
    for(int i=1;i<M;i++)
        dp[i]=dp[i-1]*p;
}
ull geth(char *s)
{
    ull h=0;
    int len=strlen(s);
    for(int i=0;i<len;i++)
        h=h*p+s[i];
    return h;
}
void gethash(char *s)
{
    int len=strlen(s);
    h[0]=0;
    for(int i=0;i<len;i++)
        h[i+1]=h[i]*p+s[i];
}

int main()
{
    scanf("%d",&t);
    init();
    while(t--)
    {
        scanf("%s%s",u+1,v+1);
        k=geth(u+1);
        gethash(v+1);
        a=strlen(u+1);
        b=strlen(v+1);
        int ans=0;
        for(int i=0;i+a<=b;i++)
        {
            ull tmp=h[i+a]-h[i]*dp[a];
            if(tmp==k)
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}