天天看點

HDOJ2117 簡單模拟題 Just a Numble

Just a Numble

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3581    Accepted Submission(s): 1797

Problem Description Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed  

Input Each line of input will contain a pair of integers for n and m(1<=n<=10^7,1<=m<=10^5)  

Output For each line of input, your program should print a numble on a line,according to the above rules  

Sample Input

4 2
5 7
123 123
        

Sample Output

5
0
8
        

Author YBB  

Source HDU 2007-10 Programming Contest_WarmUp  

Recommend 威士忌   |   We have carefully selected several similar problems for you:   2114  2115  2116  2113  2119 

好像沒什麼好講的,就是求1/n的第m位的數字是多少。模拟除法運算就OK 代碼如下:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;


int main(){
    int n,m,tot,tmp,res,x;
    std::ios::sync_with_stdio(false);
    while (cin >> n >> m) {
         tot=0;
         res=0;
         tmp=1;
         while (tot<=m) {
            res=tmp%n;
            tot++;
            x=tmp/n;
            tmp=res;
            tmp=tmp*10;
         }
         cout << x << endl;
    }
    return 0;
}