天天看點

UVaOJ 10003 Cutting Sticks(區間DP)

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery,Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of workrequires that they only make one cut at a time.

It is easy to notice that different selections in the order of cutting can led to different prices. Forexample, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end.There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a priceof 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6.Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 =20, which is a better price.

Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.

Input

The input will consist of several input cases. The first line of each test case will contain a positivenumber l that represents the length of the stick to be cut. You can assume l < 1000. The next line willcontain the number n (n < 50) of cuts to be made.

The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cutshave to be done, given in strictly increasing order.

An input case with l = 0 will represent the end of the input.

Output

You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost ofcutting the given stick. Format the output as shown below.

Sample Input

100

3

25 50 75

10

4

4 5 7 8

Sample Output

The minimum cutting is 200.

The minimum cutting is 22.

題目大意:你的老闆要你切一些木棒,以不同的順序切木棒有不同的花費。例如一根長為10的木棒,要在距離木棒一端2、4、7的位置切斷,如果先切2,再切4,最後切7,那麼花費為10 + 8 + 6 = 24;而如果換一個順序切,譬如先切4,再切2,最後切7,那麼總花費就是10 + 6 + 4 = 20。現在給你木棒的長度以及切割點的位置,求切木棒的最小花費。

解題思路:剛看到這個問題的我是懵逼的,後來進過一波反向思考,就搞懂了。我們可以把整個過程反過來,将問題看做合并木棒使得總花費最小(與合并石子的問題一樣),而每次合并木棒的花費就是兩根木棒的長度之和。是以求出每根木棒的長度,然後區間DP即可。

代碼如下:

#include <cstdio>
#include <algorithm>
#include <climits>
#include <cstring>
#include <cmath>

using namespace std;

const int maxn = 55;

int dp[maxn][maxn];
int stick[maxn],sum[maxn],pos[maxn];

int main()
{
    int n,len;
    while(scanf("%d",&len) != EOF && len){
        scanf("%d",&n);
        for(int i = 1;i <= n;i++){
            scanf("%d",&pos[i]);

        }
        for(int i = 1;i <= n;i++){
            stick[i] = pos[i] - pos[i - 1];
            sum[i] = sum[i - 1] + stick[i];
        }
        stick[n + 1] = len - pos[n];
        sum[n + 1] = sum[n] + stick[n + 1];
        memset(dp,0,sizeof(dp));
        for(int l = 1;l <= n;l++){
            for(int i = 1;i <= n - l + 1;i++){
                int j = i + l;
                dp[i][j] = INT_MAX;
                for(int k = i;k <= j;k++){
                    dp[i][j] = min(dp[i][j],dp[i][k] + dp[k + 1][j] + sum[j] - sum[i - 1]);
                }
            }
        }
        printf("The minimum cutting is %d.\n",dp[1][n + 1]);
    }
    return 0;
}