天天看點

杭電 1004 Let the Balloon RiseLet the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 138114    Accepted Submission(s): 54553

Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5 green red blue red red 3 pink orange pink 0  

Sample Output

red pink

這道題用c++的STL裡的map十分合适,直接建立一個以string為鍵,int為值的map 然後周遊出最大的

#include<iostream>
#include<cstdio>
#include<string>
#include<map>
using namespace std;
int main()
{
    string s2;
    map<string,int>m1;//建立map對象m1;鍵為string類型,值為int類型
    int n;
    while(cin>>n&&n>0){
        m1.clear();
        for(int i=0;i<n;i++){
            cin>>s2;
            m1[s2]++;
        }
        int max1=0;
        string s3;
        map<string,int>::iterator i1;
        for(i1=m1.begin();i1!=m1.end();i1++){
            if(i1->second>max1){
                    max1=(*i1).second;
                    s3=(*i1).first;
            }
        }
        cout<<s3<<endl;
    }
    return 0;
}