天天看點

hdu 3697 貪心Selecting courses

Selecting courses

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 62768/32768 K (Java/Others)

Total Submission(s): 1851    Accepted Submission(s): 468

Problem Description     A new Semester is coming and students are troubling for selecting courses. Students select their course on the web course system. There are n courses, the ith course is available during the time interval (A i,B i). That means, if you want to select the ith course, you must select it after time Ai and before time Bi. Ai and Bi are all in minutes. A student can only try to select a course every 5 minutes, but he can start trying at any time, and try as many times as he wants. For example, if you start trying to select courses at 5 minutes 21 seconds, then you can make other tries at 10 minutes 21 seconds, 15 minutes 21 seconds,20 minutes 21 seconds… and so on. A student can’t select more than one course at the same time. It may happen that no course is available when a student is making a try to select a course

You are to find the maximum number of courses that a student can select.

Input There are no more than 100 test cases.

The first line of each test case contains an integer N. N is the number of courses (0<N<=300)

Then N lines follows. Each line contains two integers Ai and Bi (0<=A i<B i<=1000), meaning that the ith course is available during the time interval (Ai,Bi).

The input ends by N = 0.

Output For each test case output a line containing an integer indicating the maximum number of courses that a student can select.

Sample Input

2
1 10
4 5
0
        

Sample Output

2
        

Source 2010 Asia Fuzhou Regional Contest 

題目描述:有n個課程,每個課程有一個時間段選課(為開區間),一個人可以從任意時刻選課,每隔五分中選一次課,問最多能夠選多少們課?

分析: 這裡隻給出解法,先将每個選課區間按結束時間排序,然後枚舉前0--4分鐘,之後枚舉選課時間,對每個選課時間看能否選一門課注意這裡隻能選擇排序後的最早滿足條件的一門,之後記錄最大值即可

#include<stdio.h>
#include<algorithm>
#include<string.h>
#define N 400
using namespace std;
int vist[N];
struct node
{
    int x,y;
}a[N];
bool cmp(node a,node b)
{
    if(a.y!=b.y)
        return a.y<b.y;
    else
        return a.x<b.x;
}
int main()
{
    int n,i,max,j,k,num;
    while(scanf("%d",&n),n!=0)
    {
        for(i=0;i<n;i++)
            scanf("%d%d",&a[i].x,&a[i].y);
        sort(a,a+n,cmp);
        max=-1;
        for(i=0;i<5;i++)
        {
            memset(vist,0,sizeof(vist));
            num=0;
            for(j=i;j<a[n-1].y;j+=5)
            {
                for(k=0;k<n;k++)
                {
                    if(!vist[k]&&a[k].x<=j&&j<a[k].y)
                    {
                        num++;
                        vist[k]=1;
                        break;
                    }
                }
            }
            if(num>max)
                max=num;
        }
        printf("%d\n",max);
    }
    return 0;
}