天天看點

poj1797 Heavy Transportation dijkstra變形

Heavy Transportation

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 36131 Accepted: 9549

Description

Background

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.

Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5
      

Sample Output

Scenario #1:
4      

題意:

火車從1點運到n點,每條路都有個限重,找一條路的所能承受的限重最大

相當于 :給定一個無向圖,求從1到n的路徑上的最小值的最大值。

就是說,從1到n可能有多條路徑,每條路徑上都有一個權值最小的邊,問這些邊的最大值。

思路:dijkstra的變形  由原來的

if(!vis[j]&&dis[j]>dis[pos]+value[pos][j])
{
	dis[j]=dis[pos]+value[pos][j];
}
           

變為

if(!vis[j]&&dis[j]<min(dis[pos],value[pos][j]))
{
	dis[j]=min(dis[pos],value[pos][j]);
}
           

同時不要忘記對輸入的value數組的初始化指派進行處理 ,是一個容易WA的點

#include<iostream>
#include<cmath>
#include<cstdio>
#include<iomanip>
#include<cstring>
#include<stdlib.h>
#include<string>
#include<algorithm>
#include<queue>
using namespace std;
#define MAXN 4500
#define INF 0xFFFFFFF
int value[MAXN][MAXN];/*儲存的是邊權值*/
int dis[MAXN];/*儲存源點到任意點之間的最短路*/
int vis[MAXN];/*記錄頂點是否沒取過*/
int n,m;
void input()
{
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=n;j++)
		{
			value[i][j]=0;
		}
	}
	int u,v,s;
	for(int i=0;i<m;i++)
	{
		scanf("%d%d%d",&u,&v,&s);
		if(s>value[u][v])
		{
			value[u][v]=s;
			value[v][u]=s;
		}
	}
}
void dijkstra()
{
	memset(vis,false,sizeof vis);
	for(int i=1;i<=n;i++)
	{
		dis[i]=0;
	}
	dis[1]=INF;
	for(int i=1;i<=n;i++)
	{
		int pos=-1;
		for(int j=1;j<=n;j++)
		{
			if(!vis[j]&&(pos==-1||dis[j]>dis[pos]))
			{
				pos=j;
			}
		}
		vis[pos]=true;
		for(int j=1;j<=n;j++)
		{
			if(!vis[j]&&dis[j]<min(dis[pos],value[pos][j]))
			{
				dis[j]=min(dis[pos],value[pos][j]);
			}
		}

	}
}
int main()
{
	int t;
	scanf("%d",&t);
	for(int k=1;k<=t;k++)
	{
		scanf("%d%d",&n,&m);
		input();
		dijkstra();
		printf("Scenario #%d:\n",k);
		printf("%d\n\n",dis[n]);
	}
	return 0;
}