天天看点

BGP Route Reflectors and Route Filters

<a href="http://s3.51cto.com/wyfs02/M01/25/09/wKiom1NY0dziObv6AAED5w-2As0967.jpg" target="_blank"></a>

sanjose1#show run 

Building configuration... 

Current configuration : 1338 bytes 

version 12.4 

service timestamps debug datetime msec 

service timestamps log datetime msec 

no service password-encryption 

hostname sanjose1 

boot-start-marker 

boot-end-marker 

no aaa new-model 

ip cef 

no ip domain lookup 

interface FastEthernet0/0 

no ip address 

shutdown 

duplex half 

!          

interface Serial1/0 

ip address 192.168.1.5 255.255.255.252 

serial restart-delay 0 

clock rate 128000 

router rip 

version 2 

network 192.168.1.0 

no auto-summary 

router bgp 100 

no synchronization 

bgp log-neighbor-changes 

neighbor 192.168.1.6 remote-as 100 

no ip http server 

no ip http secure-server 

!control-plane 

gatekeeper 

shutdown  

line con 0 

exec-timeout 0 0 

logging synchronous 

stopbits 1 

line aux 0 

line vty 0 4 

end 

sanjose2#show run 

*Apr 14 13:23:12.559: %SYS-5-CONFIG_I: Configured from console by console 

Current configuration : 1664 bytes 

hostname sanjose2 

interface Loopback0 

ip address 10.2.2.1 255.255.255.0 

ip address 192.168.1.6 255.255.255.252 

interface Serial1/1 

ip address 172.24.1.17 255.255.255.0 

network 10.0.0.0 

network 172.24.0.0 

neighbor 172.24.1.18 remote-as 100 

neighbor 172.24.1.18 route-reflector-client    配置路由反射 

neighbor 192.168.1.5 remote-as 100 

neighbor 192.168.1.5 route-reflector-client    配置路由反射 

neighbor 192.168.1.5 prefix-list zhang out     路由过滤 

ip prefix-list zhang seq 5 permit 198.0.0.0/8   路由过滤 

control-plane 

sanjose3#show run 

Current configuration : 1440 bytes 

hostname sanjose3 

ip address 198.133.219.1 255.255.255.0 

ip address 172.24.1.18 255.255.255.0 

network 198.133.219.0 

aggregate-address 198.0.0.0 255.0.0.0   汇总 

neighbor 172.24.1.17 remote-as 100 

sanjose2#show ip prot 

Routing Protocol is "rip" 

 Outgoing update filter list for all interfaces is not set 

 Incoming update filter list for all interfaces is not set 

 Sending updates every 30 seconds, next due in 12 seconds 

 Invalid after 180 seconds, hold down 180, flushed after 240 

 Redistributing: rip 

 Default version control: send version 2, receive version 2 

   Interface             Send  Recv  Triggered RIP  Key-chain 

   Serial1/0             2     2                                     

   Serial1/1             2     2                                     

   Loopback0             2     2                                     

 Automatic network summarization is not in effect 

 Maximum path: 4 

 Routing for Networks: 

   10.0.0.0 

   172.24.0.0 

   192.168.1.0 

 Routing Information Sources: 

   Gateway         Distance      Last Update 

 Distance: (default is 120) 

Routing Protocol is "bgp 100" 

 Route Reflector for address family IPv4 Unicast, 2 clients 

 Route Reflector for address family IPv6 Unicast, 2 clients 

 Route Reflector for address family VPNv4 Unicast, 2 clients 

 Route Reflector for address family IPv4 Multicast, 2 clients 

 Route Reflector for address family IPv6 Multicast, 2 clients 

 IGP synchronization is disabled 

 Automatic route summarization is disabled 

 Neighbor(s): 

   Address          FiltIn FiltOut DistIn DistOut Weight RouteMap 

   172.24.1.18                                           

   192.168.1.5                                           

 Maximum path: 1 

   172.24.1.18          200      00:10:16 

 Distance: external 20 internal 200 local 200 

sanjose2#show ip bgp 198.0.0.0 

BGP routing table entry for 198.0.0.0/8, version 5 

Paths: (1 available, best #1, table Default-IP-Routing-Table) 

 Advertised to update-groups: 

    1          2          

 Local, (aggregated by 100 172.24.1.18), (Received from a RR-client) 

   172.24.1.18 from 172.24.1.18 (172.24.1.18) 

     Origin IGP, metric 0, localpref 100, valid, internal, atomic-aggregate, best 

sanjose1#show ip route 

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP 

      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area  

      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 

      E1 - OSPF external type 1, E2 - OSPF external type 2 

      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 

      ia - IS-IS inter area, * - candidate default, U - per-user static route 

      o - ODR, P - periodic downloaded static route 

Gateway of last resort is not set 

    172.24.0.0/24 is subnetted, 1 subnets 

R       172.24.1.0 [120/1] via 192.168.1.6, 00:00:07, Serial1/0 

    10.0.0.0/24 is subnetted, 1 subnets 

R       10.2.2.0 [120/1] via 192.168.1.6, 00:00:07, Serial1/0 

    192.168.1.0/30 is subnetted, 1 subnets 

C       192.168.1.4 is directly connected, Serial1/0 

B    198.0.0.0/8 [200/0] via 172.24.1.18, 00:15:15 

sanjose1#tclsh 

sanjose1(tcl)#foreach address { 

+&gt;10.2.2.1 

+&gt;192.168.1.5 

+&gt;192.168.1.6 

+&gt;172.24.1.17 

+&gt;172.24.1.18 

+&gt;198.133.219.1 

+&gt;} { 

+&gt;ping $address } 

Type escape sequence to abort. 

Sending 5, 100-byte ICMP Echos to 10.2.2.1, timeout is 2 seconds: 

!!!!! 

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/48/100 ms 

Sending 5, 100-byte ICMP Echos to 192.168.1.5, timeout is 2 seconds: 

Success rate is 100 percent (5/5), round-trip min/avg/max = 60/78/128 ms 

Sending 5, 100-byte ICMP Echos to 192.168.1.6, timeout is 2 seconds: 

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/35/68 ms 

Sending 5, 100-byte ICMP Echos to 172.24.1.17, timeout is 2 seconds: 

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/41/124 ms 

Sending 5, 100-byte ICMP Echos to 172.24.1.18, timeout is 2 seconds: 

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/39/80 ms 

Sending 5, 100-byte ICMP Echos to 198.133.219.1, timeout is 2 seconds: 

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/33/72 ms

本文转自zhang25yun51CTO博客,原文链接:http://blog.51cto.com/1585654/1402023 ,如需转载请自行联系原作者

继续阅读