天天看点

hdu 1423 Greatest Common Increasing SubsequenceGreatest Common Increasing Subsequence

Greatest Common Increasing Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2896    Accepted Submission(s): 904

Problem Description This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.  

Input Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.  

Output output print L - the length of the greatest common increasing subsequence of both sequences.  

Sample Input

1

5
1 4 2 5 -12
4
-12 1 2 4
        

Sample Output

2
        

题意:

最长公共上升子序列(LCIS)

AC代码

#include<iostream>
using namespace std;
int dp[512][512],a[512],b[512];
int main()
{
     int i,j,t,n,m,Max,flag=0;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=1;i<=n;i++) scanf("%d",&a[i]);
		scanf("%d",&m);
		for(i=1;i<=m;i++) scanf("%d",&b[i]);
		memset(dp,0,sizeof(dp));
		for(i=1;i<=n;i++)
		{
			Max=0;
			for(j=1;j<=m;j++)
			{
				dp[i][j]=dp[i-1][j];
				if (a[i]>b[j]&&Max<dp[i-1][j])
					Max=dp[i-1][j];
				if (a[i]==b[j]) dp[i][j]=Max+1;
			}
		}
		Max=0;
		for(i=1;i<=m;i++) 
			if (Max<dp[n][i]) 
				Max=dp[n][i];
			if(flag)
				printf("\n");
		flag++;
		printf("%d\n",Max);
		
	}
	return 0;
}           

谢谢阅读!