天天看点

uva 573(数学)

题目:

A snail is at the bottom of a 6-foot well and wants to climb to the top.The snail can climb 3 feetwhile the sun is up, but slides down 1 foot at night while sleeping.The snail has a fatigue factorof 10%, which means that on each successive day the snail climbs10%

uva 573(数学)

3 = 0.3 feet less thanit did the previous day. (The distance lost to fatigue is always 10% of thefirst day's climbingdistance.) On what day does the snail leave the well, i.e., what is the firstday during whichthe snail's height exceeds 6 feet? (A day consists of a period of sunlightfollowed by a period ofdarkness.) As you can see from the following table, the snail leaves the wellduring the third day.

Day Initial Height Distance Climbed Height After Climbing Height After Sliding
1 0' 3' 3' 2'
2 2' 2.7' 4.7' 3.7'
3 3.7' 2.4' 6.1' -

Your job is to solve this problem in general. Depending on the parametersof the problem, thesnail will eventually either leave the well or slide back to the bottom ofthe well. (In other words,the snail's height will exceed the height of the well or become negative.)You must find out whichhappens first and on what day.

input

The input file contains one or more test cases, each on a line by itself.Each line contains fourintegers H, U, D, and F, separated by a single space. If H= 0 it signals the end of the input;otherwise, all four numbers will be between 1 and 100, inclusive. H is theheight of the well infeet, U is the distance in feet that the snail can climb during the day,D is the distance in feetthat the snail slides down during the night, and F is the fatigue factorexpressed as a percentage.The snail never climbs a negative distance. If the fatigue factor dropsthe snail's climbing distancebelow zero, the snail does not climb at all that day. Regardless of how farthe snail climbed, it always slides D feet at night.

output

For each test case, output a line indicating whether the snail succeeded(left the well) or failed(slid back to the bottom) and on what day. Format the output exactly as shown in the example.

sample input

6 3 1 10
10 2 1 50
50 5 3 14
50 6 4 1
50 6 3 1
1 1 1 1
0 0 0 0
      

sample output

success on day 3
failure on day 4
failure on day 7
failure on day 68
success on day 20
failure on day 2      

题解:蜗牛爬井,需要注意的是当每天能爬的距离减去增长后的疲劳值小于零,就置为零。

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

int main() {
	double h, u, d, f, H, n;
	int day;
	while (scanf("%lf %lf %lf %lf", &h, &u , &d, &f) != EOF && h) {
		day = 1;
		H = 0;
		n = 1;
		f = f * 0.01;
		while (1) {
			if (day == 1)
				H += u;
			else {
				double temp = u - u * f * n;
				if (temp < 0)
					temp = 0;
				H += temp;
				n++;
			}
			if (H > h) {
				printf("success on day %d\n", day);
				break;
			}
			H -= d;
			if (H < 0) {
				printf("failure on day %d\n", day);
				break;
			}
			day++;
		}
	}
	return 0;
}