天天看点

hdu2844—Coins(多重背包)Coins

题目链接:传送门

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15108    Accepted Submission(s): 5994

Problem Description Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.  

Input The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.  

Output For each test case output the answer on a single line.  

Sample Input

3 101 2 4 2 1 12 51 4 2 10 0  

Sample Output

84  

Source 2009 Multi-University Training Contest 3 - Host by WHU  

解题思路:多重背包

注意:用多重背包解会卡常数时间,单调队列优化多重背包(0(N*V))一直tle,将完全背包的情况剥离出来,才过掉。

二进制拆分

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#include <stack>
#include <queue>

using namespace std;

typedef long long ll;
typedef pair<int,int>PA;
const int N = 120;
const int M = 100119;
const int INF = 0x3fffffff;

int cost[N],num[N],dp[M];

int main()
{
    int n,m;
    while( ~scanf("%d%d",&n,&m)&&n&&m ){
        memset( dp , 0 , sizeof(dp) );
        for( int i = 0 ; i < n ; ++i ){
            scanf("%d",&cost[i]);
        }
        for( int i = 0 ; i < n ; ++i ){
            scanf("%d",&num[i]);
        }
        for( int i = 0 ; i < n ; ++i ){
            //当物品数量乘花费>=m,用完全背包解
            if( cost[i]*num[i] >= m ){
                for( int j = cost[i] ; j <= m ; ++j ){
                    dp[j] = max( dp[j] , dp[j-cost[i]]+cost[i] );
                }
                continue;
            }
            int rec = num[i],k = 1;
            //将物品数量分解成二进制数用01背包解
            //当时k<rec写成k<num[i]runtime了m次,心累
            while( k < rec ){
                for( int j = m ; j >= k*cost[i] ; --j ){
                    dp[j] = max( dp[j] , dp[j-k*cost[i]]+cost[i]*k );
                }
                rec = rec-k;
                k = k*2;
            }
            for( int j = m ; j >= rec*cost[i] ; --j ){
                dp[j] = max( dp[j] , dp[j-rec*cost[i]]+cost[i]*rec );
            }
        }
        int ans = 0;
        for( int i = 1 ; i <= m ; ++i ){
            if( dp[i] == i ) ++ans;
        }
        printf("%d\n",ans);
    }
    return 0;
}
           

单调队列优化

#include <iostream>
#include <stack>
#include <vector>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

const int N = 110;
const int M = 100010;
const int INF = 0x3fffffff;

struct Node{
    int id,val;
    Node(){}
    Node(int _id,int _v){
        id = _id; val = _v;
    }
}q[M];

int dp[M],V;   V是所有商品的总价值
int cnt[N],v[N];

void ZeroOnePack(int cost,int value)
{
    for(int i = V; i >= cost; --i)
        dp[i] = max(dp[i],dp[i-cost]+value);
}

void CompletePack(int cost,int value)
{
    for(int i = cost; i <= V; ++i)
        dp[i] = max(dp[i],dp[i-cost]+value);
}

void MultiPack(int num,int cost,int value)
{
    for(int j = 0; j < cost; ++j){
        int head = 1,tail = 0;
        for(int k = j,i = 0; k <= V; k += cost, ++i){
            int r = dp[k]-i*value;
            while(head <= tail && r >= q[tail].val) tail--;
            q[++tail] = Node(i,r);
            while(q[head].id < i-num) head++;
            dp[k] = q[head].val+i*value;
        }
    }
}

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)){
        if(n == 0 && m == 0) break;
        V = m;
        for(int i = 0; i < n; ++i) scanf("%d",&v[i]);
        for(int i = 0; i < n; ++i) scanf("%d",&cnt[i]);
        memset(dp,0,sizeof(dp));
        for(int i = 0; i < n; ++i){
            if(m <= cnt[i]*v[i]) CompletePack(v[i],v[i]);
            else MultiPack(cnt[i],v[i],v[i]);
        }
//        for(int i = 1; i <= m; ++i)
//            cout << dp[i] << " ";
        int ans = 0;
        for(int i = 1; i <= m; ++i)
            if(dp[i] == i) ans++;
        printf("%d\n",ans);
    }
    return 0;
}