天天看点

【剑指紫金港】1040 Longest Symmetric String DP回文字符串A 1040 Longest Symmetric String DP回文字符串

A 1040 Longest Symmetric String DP回文字符串

题目链接

Problem Description

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given

Is PAT&TAP symmetric?

, the longest symmetric sub-string is

s PAT&TAP s

, hence you must output

11

.

Input

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?
           

Sample Output:

11
           

AC代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1005;
int dp[maxn][maxn];

int main(){
    string str;
    getline(cin,str);
    int maxl=1,len=str.size();
    //fill(dp[0],dp[0]+maxn*maxn,0);
    for(int i=0;i<len;i++){
        dp[i][i]=1;
        if(i<len-1 && str[i]==str[i+1]){
            dp[i][i+1]=1;
            maxl=2;
        }
    }
    for(int L=3;L<=len;L++){
        for(int i=0;i+L-1<len;i++){
            int j=i+L-1;
            if(str[i]==str[j] && dp[i+1][j-1]==1){
                dp[i][j]=1;
                maxl=L;
            }
        }
    }
    printf("%d",maxl);
    return 0;
}