天天看点

POJ 2390-Bank Interest-水Bank Interest

Bank Interest

Problem Description

Farmer John made a profit last year! He would like to invest it well but wonders how much money he will make. He knows the interest rate R (an integer between 0 and 20) that is compounded annually at his bank. He has an integer amount of money M in the range 100..1,000,000. He knows how many years Y (range: 0..400) he intends to invest the money in the bank. Help him learn how much money he will have in the future by compounding the interest for each year he saves. Print an integer answer without rounding. Answers for the test data are guaranteed to fit into a signed 32 bit integer.

Input

* Line 1: Three space-separated integers: R, M, and Y

Output

* Line 1: A single integer that is the number of dollars FJ will have after Y years.

Sample Input

5 5000 4
       

Sample Output

6077
       
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
    int a;
    double r,m,y;
    scanf("%lf %lf %lf",&r,&m,&y);
    a=pow(1+r*0.01,y)*m;
    printf("%d",a);
    return 0;
}