天天看点

1100 Mars Numbers (20 分)1100 Mars Numbers (20 分)

1100 Mars Numbers (20 分)

People on Mars count their numbers with base 13:

Zero on Earth is called “tret” on Mars.

The numbers 1 to 12 on Earth is called “jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec” on Mars, respectively.

For the next higher digit, Mars people name the 12 numbers as “tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou”, respectively.

For examples, the number 29 on Earth is called “hel mar” on Mars; and “elo nov” on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4

29

5

elo nov

tam

Sample Output:

hel mar

may

115

13

Note

  1. 题意: 10与13进制转换
  2. 思路: 十到十三:找数组输出 十三到十/13分情况讨论

Code

#include<iostream>
#include<string>
using namespace std;
string a[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string b[13] = {" ", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
string n;
void funchuman(int num){            //两位的还要考虑第二位为零不输出
    if (num >= 13) {
        if (num % 13 == 0) cout << b[num/13];
        else cout << b[num/13]  << " " << a[num%13];
    }
    else cout << a[num];
}
void funcMartian(void){
    int t1 = 0, t2 = 0;
    string s1 = n.substr(0, 3), s2; //s1是高位,用t1存
    if (n.length() > 4) s2 = n.substr(4, 3);
    for (int j = 1; j <= 12; j++) {
        if (s1 == b[j]) t1 = j;
        if (s1 == a[j] || s2 == a[j]) t2 = j;  
    }
    cout << t1 * 13 + t2;
}
int main() {
    int num;
    cin >> num;
    getchar();
    for (int i = 0; i < num; i++) {
        getline(cin, n);
        //len = n.length();
        if (n[0] >= '0' && n[0] <= '9')
            funchuman(stoi(n));
        else
            funcMartian();
        cout << endl;
    }
    return 0;