天天看点

二叉树(Tree Recovery)

Tree Recovery

Time Limit:3000MS Memory Limit:Unknown 64bit IO Format:%lld & %llu

Submit  Status

Description

二叉树(Tree Recovery)

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

D
                                   / \
                                  /   \
                                 B     E
                                / \     \
                               /   \     \ 
                              A     C     G
                                         /
                                        /
                                       F
      

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).

For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

Input Specification 

The input file will contain one or more test cases. Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

Output Specification 

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input 

DBACEGF ABCDEFG
BCAD CBAD
      

Sample Output 

ACBFGED
CDAB
      

【分析】

       根据先序遍历确定二叉树的根root,再由根root根据中序遍历,确定左右子树,根据root在先序遍历与中序遍历中的位置,划分出左右子树的范围。这样又出现了两棵树,同时我们还具有这两棵的先序遍历和中序遍历。使用递归建树,已知树后,对树进行后序遍历得到结果。

       创建数组 lch 和 rch ,数组的下标为结点,数组的元素是结点所对应的左结点和右结点(的下标)。可以利用这两个数组进行建树。我们只要已知整棵树的根的下标,就可以通过下标,得知左右结点的值,依次得出各个结点的值(在遍历过程中)。

用java语言编写程序,代码如下:

import java.io.BufferedInputStream;
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner input = new Scanner(new BufferedInputStream(System.in));
		final int maxn = 1000 + 5;
		while(input.hasNext()) {
			char[] preorder = input.next().toCharArray();
			char[] inorder = input.next().toCharArray();
			int n = preorder.length;
			
			int[] lch = new int[maxn];//左结点
			int[] rch = new int[maxn];//右结点
			build(0, n - 1, 0, n - 1, preorder, inorder, lch, rch);//建立二叉树
			post_traversal(preorder[0], lch, rch);//后序遍历
			System.out.println();
		}
	}
	
	//把preorder[l1...r1]和inorder[l2...r2]建成一棵二叉树,返回树根
	public static int build(int l1, int r1, int l2, int r2, 
			char[] preorder, char[] inorder, int[] lch, int[] rch) {
		if(l2 > r2) return 0;//空树
		int root = preorder[l1];
		int p = l2;
		while(inorder[p] != root) p++;
		int cnt = p - l2;//左子树的结点个数
		lch[root] = build(l1 + 1, l1 + cnt, l2, p - 1, preorder, inorder, lch, rch);
		rch[root] = build(l1 + cnt + 1, r1, p + 1, r2, preorder, inorder, lch, rch);
		//System.out.println(root);
		return root;
	}
	
	public static void post_traversal(char root, int[] lch, int[] rch) {
		if(root >= 'A' && root <= 'Z') {
			post_traversal((char) lch[root], lch, rch);
			post_traversal((char) rch[root], lch, rch);
			System.out.print(root);			
		}
	}
	
	
}