天天看点

PAT 甲级 1117  Eddington Number

1117 Eddington Number (25 point(s))

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

Sample Input:

10
6 7 6 9 3 10 8 2 7 8      

Sample Output:

6      

经验总结:

AC代码

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=100010;
int n,a[maxn],t;

int main()
{
  scanf("%d",&n);
  int maxnum=-1,minnum=0x3fffffff;
  for(int i=0;i<n;++i)
  {
    scanf("%d",&a[i]);
    maxnum=a[i]>maxnum?a[i]:maxnum;
    minnum=a[i]<minnum?a[i]:minnum;
  }
  sort(a,a+n);
  for(int i=maxnum;i>=0;--i)
  {
    int *p=upper_bound(a,a+n,i);
    if(n-(int)(p-a)>=i)
    {
      printf("%d\n",i);
      break;
    }
  }
  return 0;
}