天天看点

PAT 1109 Group Photo

原题链接:1109 Group Photo (25分)

关键词:模拟、结构体排序

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

  1. The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;
  2. All the people in the rear row must be no shorter than anyone standing in the front rows;
  3. In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);
  4. In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);

When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N (≤104​​ ), the total number of people, and K (≤10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

Output Specification:

For each case, print the formation – that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:

10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159
           

Sample Output:

Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John
           

题目大意: 按照他给的规则,将一堆人排成拍照片的格式。

分析: 在结构体内定义好比较规则,并实现排序,给每个人打上编号后,按一行一行输出。

代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e4 + 10;
int n, k;   //n人数 k行数

struct People {
    char name[10];
    int high;
    bool operator<(const People b) const {    //按身高递减,身高相同按名字递增
        if (high != b.high) return high > b.high;
        return strcmp(name, b.name) < 0;
    }
} p[maxn];

int main(){
    cin >> n >> k;
    for(int i = 0; i < n; i ++ ) scanf("%s %d", p[i].name, &p[i].high);  //name哪里不需要加&
    sort(p, p + n);
    
    int idx = 0;    //打上编号,控制输出
    for (int i = 0; i < k; i++) {   //k行
        int len = n / k;    //直接除结果就是整数部分,一行的人
        
        //最后一排,加上多出来的人数
        if (i == 0) len += n % k;
        vector<int> line(len + 1);
        int mid = len / 2 + 1;      //中间的人
        for (int r = mid, l = mid - 1; l > 0 || r <= len; l--, r++) {
            //从中间的开始向两边枚举
            if (r <= len) line[r] = idx++;
            if (l > 0) line[l] = idx++;
        }
        
        for (int j = 1; j <= len; j++) {
            if (j != 1) printf(" ");
            printf("%s", p[line[j]].name);
        }
        printf("\n");
    }

    return 0;
}
           

补充:

round():四舍五入
floor(): 不大于自变量的最大整数
ceil():不小于自变量的最大整数