天天看点

hdu-1078-FatMouse and Cheese-记忆化搜索 FatMouse and Cheese

FatMouse and Cheese

Problem Description FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

Input There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 

The input ends with a pair of -1's. 

Output For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1
        

Sample Output

37

        

题意:n*n的格子里有相应的食物,老鼠每次只能在水平和竖直方向上最多走k步(一个格子最多有4*k种),并且下一步要比上一步的食物多,求最多能吃到的食物。

思路:用dp数组记录状态,从(0,0)开始一直递归到不能递归,每个格子的dp值为其周围最大的dp值加上其本身,如果某个格子已经有dp值了,则返回,否则会超时

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int n,k,ans;
int ma[105][105];
int dp[105][105];
int dir[4][2]={-1,0, 0,1, 1,0, 0,-1};
void dfs(int x,int y)
{
    int m=0;
    int maxx=0;
    if(dp[x][y]) return;
    for(int i=0 ; i < 4; i++)
    {
        for(int j=1 ; j <= k ; j++)
        {
            int xx=x+dir[i][0]*j;
            int yy=y+dir[i][1]*j;
            if(xx>=0&&xx<n&&yy>=0&&yy<n&&ma[xx][yy]>ma[x][y])
            {
                dfs(xx,yy);
                if(m<dp[xx][yy])
                    m=dp[xx][yy];
            }
        }
    }
    dp[x][y]=m+ma[x][y];
}
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&k))
    {
        if(n==-1 && k==-1) break;
        memset(dp,0,sizeof(dp));
        for(i=0 ; i < n ; i++)
            for(j=0 ; j < n ; j++)
                scanf("%d",&ma[i][j]);
        dfs(0,0);
//        for(i=0 ; i < n ; i++)
//        {
//            for(j=0 ; j < n ; j++)
//            {
//                printf("%d ",dp[i][j]);
//            }
//            printf("\n");
//        }
        printf("%d\n",dp[0][0]);
    }
    return 0;
}