天天看点

PAT甲级1054 The Dominant Color

题目

1054 The Dominant Color (20 分)

Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2​24​​ ). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3

0 0 255 16777215 24

24 24 0 0 24

24 0 24 24 24

Sample Output:

24

题目意思

在一个n*m的二维数组里,找到出现次数超过一半的那个数,输出出来。保证一定有这个数。

思路

用map是真的很方便。但是不怎么会用map所以学习了一波map。map的这种遍历方式codeblock编译不了,就很难受。还是多记住吧。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<map>

using namespace std;

int main()
{
    int m,n;
    scanf("%d%d",&m,&n);
    int mz,k=0;
    map<int,int>hx;
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            scanf("%d",&mz);
            hx[mz]++;
        }
    }
    int temp = n*m/2;
    for(auto elem:hx)
    {
        if(elem.second>temp)
        {
            printf("%d",elem.first);
            break;
        }
    }
   return 0;
}