天天看点

HDU 1017 A Mathematical Curiosity(枚举+mod)                                                              A Mathematical Curiosity

                                                              A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 35537    Accepted Submission(s): 11341

Problem Description Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

  Input You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

  Output For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

Sample Input

1

10 1
20 3
30 4
0 0
        

Sample Output

Case 1: 2
Case 2: 4
Case 3: 5
        

题解: 从0到n枚举 a,b(a<b),如果(a^2+b^2+m)%(a*b)==0, 则 result+1。。。。。

AC代码:

#include<iostream>
#include<cstdio>
using namespace std;
int main(){
    int T,n,m,flag=0,result;
    cin>>T;
    while(T--){
        flag=0;
        while(cin>>n>>m){
            if(m==0&&n==0) break;
            else{
                flag++;
                result=0;
                for(int a=1;a<n;a++)
                    for(int b=a+1;a<b&&b<n;b++){
                        int r1=a*a+b*b+m;
                        int r2=a*b;
                        if(r1%r2==0) result++;
                    }
                cout<<"Case "<<flag<<": "<<result<<endl;
            }
        }
       if(T!=0) cout<<endl;
    }
    return 0;
}