天天看点

hdu1002 高精度之A+B

题目来源:hdoj1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 243480    Accepted Submission(s): 46965

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2

1 2

112233445566778899 998877665544332211

Sample Output

Case 1:

1 + 2 = 3

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

Author

Ignatius.L

Recommend

We have carefully selected several similar problems for you:  

​​1008​​​ 

​​​1089​​​ 

​​​1093​​​ 

​​​1092​​​ 

​​​1009​​

解析:裸地高精度加法,具体算法请自行百度。 

代码:

#include<cstdio>
#include<cstring>
#define maxn 1000
using namespace std;

char a[maxn+100],b[maxn+100];
int c[maxn+10];

void redirect()
{
  freopen("1.in","r",stdin);
  freopen("1.out","w",stdout);
}

void work()
{
  int i,j,k=0,last=0,len1=strlen(a)-1,len2=strlen(b)-1;
  while(len1>=0 && len2>=0)
    {
      c[++k]=a[len1]-'0'+b[len2]-'0'+last;
      last=c[k]/10,c[k]%=10;
      len1--,len2--;
  }
  
  while(len1>=0)
    {
      c[++k]=a[len1]-'0'+last;
      last=c[k]/10,c[k]%=10;
      len1--;
    }  
    
  while(len2>=0)
    {
      c[++k]=b[len2]-'0'+last;
      last=c[k]/10,c[k]%=10;
      len2--;
    }
    
  while(k>0)printf("%d",c[k]),k--;    
  printf("\n");
}

int main()
{
  redirect();
  int t,i,j,k;
  scanf("%d\n",&t);
  for(i=1;i<=t;i++)
    {
      scanf("%s%s\n",a,b);
      printf("Case %d:\n%s + %s = ",i,a,b);
      work();
      if(i<t)printf("\n");
    }

  return 0;
}