天天看点

UESTC 1272 Final Pan's prime numbers

Description

Final Pan likes prime numbers very much.

One day, he want to find the super prime numbers.A prime numbers n(n>4) is a super prime number only if n-4 and n+4 are both prime numbers,too.

Your task is really easy:Give N,find the maximum super prime number n that n<=N.

Input

Only one integer N.( 4<N<10^{12} )

Output

If there is no such interger n,print'-1',otherwise print n.

Sample Input

8

Sample Output

7

#include<iostream>  
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<vector>
#include<cstring>
#include<string>
using namespace std;
typedef long long LL;
const int maxn = 1e4 + 5;
const int base = 1e9 + 7;
const int low(int x){ return x&-x; }
int T, m;
int f[maxn];
LL n;


int main(){
  //scanf("%d", &T);
  while (~scanf("%lld", &n))
  {
    if (n >= 7) printf("7\n"); else printf("-1\n");
  }
  return 0;
}