天天看點

詳解BSCI實驗四:配置BGP

步驟一:配置三台路由器接口使其連通。

R1的配置

R1(config)# interface Loopback0

R1(config-if)# ip address 1.1.1.1 255.255.255.0

R1(config)# interface Loopback1

R1(config-if)# ip address 2.2.2.2 255.255.255.0

R1(config)# interface s0

R1(config-if)# ip address 10.1.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#clock rate 64000

R2的配置

R2(config)#interface Loopback0

R2(config-if)# ip address 3.3.3.3 255.255.255.0

R2(config)#interface Loopback1

R2(config-if)# ip address 4.4.4.4 255.255.255.0

R2(config)#interface Serial0

R2(config-if)# ip address 20.1.1.1 255.255.255.0

R2(config-if)#no shutdown

R2(config)#interface Serial1

R2(config-if)# ip address 10.1.1.2 255.255.255.0

R3的配置

R3(config)#interface Loopback0

R3(config-if)# ip address 5.5.5.5 255.255.255.0

R3(config)#interface Loopback1

R3(config-if)# ip address 6.6.6.6 255.255.255.0

R3(config)#interface Serial1

R3(config-if)# ip address 20.1.1.2 255.255.255.0

R3(config-if)#clockrate 64000

R3(config-if)#no shutdown

步驟二:啟用

R1(config)#router eigrp 100 à啟用eigrp100

R1(config-router)#network 1.1.1.0 0.0.0.255 à釋出相應接口

R1(config-router)#network 10.1.1.0 0.0.0.255

R1(config-router)# no auto-summary à關閉自動彙總

R1(config)#router bgp 65001 à啟用BGP65001

R1(config-router)#no synchronization  à關閉與IGP的同步

R1(config-router)# network 2.2.2.0 mask 255.255.255.0 à釋出參與BGP網段

R1(config-router)# network 10.1.1.0 mask 255.255.255.0

R1(config-router)# neighbor 3.3.3.3 remote-as 65001  à指定鄰居

R1(config-router)# neighbor 3.3.3.3 update-source Loopback0 à更新源改為loop0接口

R1(config-router)#no auto-summary  à關閉自動彙總

R2(config)#router eigrp 100

R2(config-router)# network 3.3.3.0 0.0.0.255

R2(config-router)# network 10.1.1.0 0.0.0.255

R2(config-router)# no auto-summary

R2(config)#router bgp 65001

R2(config-router)# no synchronization

R2(config-router)# network 4.4.4.0 mask 255.255.255.0

R2(config-router)# network 10.1.1.0 mask 255.255.255.0

R2(config-router)# neighbor 1.1.1.1 remote-as 65001

R2(config-router)# neighbor 1.1.1.1 update-source Loopback0

R2(config-router)# neighbor 1.1.1.1 next-hop-self  à将自己指定為鄰居的下一跳

R2(config-router)# neighbor 5.5.5.5 remote-as 65002  à指定ebgp鄰居

R2(config-router)# neighbor 5.5.5.5 ebgp-multihop 255  à設定多跳,預設為1

R2(config-router)# neighbor 5.5.5.5 update-source Loopback0

R2(config-router)# no auto-summary 

R3(config)#router bgp 65002

R3(config-router)#network 6.6.6.0 mask 255.255.255.0

R3(config-router)# neighbor 3.3.3.3 remote-as 65001

R3(config-router)# neighbor 3.3.3.3 ebgp-multihop 255

R3(config-router)# neighbor 3.3.3.3 update-source Loopback0

R3(config-router)# no auto-summary

步驟三:配置靜态路由

R2(config)# ip route 5.5.5.0 255.255.255.0 20.1.1.2 à因R2和R3運作在不同的AS,是以要指靜态路由來達到可達性

R3(config)# ip route 3.3.3.0 255.255.255.0 20.1.1.1  à同理

步驟四:檢視路由表

R1#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets

C       1.1.1.0 is directly connected, Loopback0

     2.0.0.0/24 is subnetted, 1 subnets

C       2.2.2.0 is directly connected, Loopback1

     3.0.0.0/24 is subnetted, 1 subnets

D       3.3.3.0 [90/2297856] via 10.1.1.2, 00:09:13, Serial0

     4.0.0.0/24 is subnetted, 1 subnets

B       4.4.4.0 [200/0] via 3.3.3.3, 00:07:34  à學來了BGP路由條目

     6.0.0.0/24 is subnetted, 1 subnets

B       6.6.6.0 [200/0] via 3.3.3.3, 00:07:34

     10.0.0.0/24 is subnetted, 1 subnets

C       10.1.1.0 is directly connected, Serial0

R2#sh ip route

D       1.1.1.0 [90/2297856] via 10.1.1.1, 00:14:09, Serial1

B       2.2.2.0 [200/0] via 1.1.1.1, 00:14:05

C       3.3.3.0 is directly connected, Loopback0

C       4.4.4.0 is directly connected, Loopback1

     20.0.0.0/24 is subnetted, 1 subnets

C       20.1.1.0 is directly connected, Serial0

     5.0.0.0/24 is subnetted, 1 subnets

S       5.5.5.0 [1/0] via 20.1.1.2

B       6.6.6.0 [20/0] via 5.5.5.5, 00:18:07

C       10.1.1.0 is directly connected, Serial1

R3#sh ip route

B       2.2.2.0 [20/0] via 3.3.3.3, 00:18:06

S       3.3.3.0 [1/0] via 20.1.1.1

B       4.4.4.0 [20/0] via 3.3.3.3, 00:22:07

C       20.1.1.0 is directly connected, Serial1

C       5.5.5.0 is directly connected, Loopback0

C       6.6.6.0 is directly connected, Loopback1

B       10.1.1.0 [20/0] via 3.3.3.3, 00:22:09

步驟五:檢視bgp 概要資訊

R1#sh ip bgp summary

BGP router identifier 2.2.2.2, local AS number 65001

Neighbor V AS MsgRcvd MsgSent TblVer  InQ OutQ Up/Down  State/PfxRcd

3.3.3.3   4 65001      13      12        5    0    0 00:08:23        3

R2#sh ip bgp summary

BGP router identifier 4.4.4.4, local AS number 65001

1.1.1.1   4 65001      18      19        5    0    0 00:14:41        2

5.5.5.5   4 65002      22      23        5    0    0 00:18:42        1

R3#sh ip bgp summary

BGP router identifier 6.6.6.6, local AS number 65002

NeighborV AS MsgRcvd MsgSent TblVer  InQ OutQ Up/Down  State/PfxRcd

3.3.3.3   4 65001      27    26        5    0    0 00:22:36        3

步驟六:檢視bgp鄰居

R1#sh ip bgp neighbors

BGP neighbor is 3.3.3.3,  remote AS 65001, internal link

  BGP version 4, remote router ID 4.4.4.4

  BGP state = Established, up for 00:10:41  àIBGP鄰居已建立

  Last read 00:00:41, hold time is 180, keepalive interval is 60 seconds

R2#sh ip bgp neighbors

BGP neighbor is 1.1.1.1,  remote AS 65001, internal link

  BGP version 4, remote router ID 2.2.2.2

  BGP state = Established, up for 00:15:15  àIBGP鄰居已建立

BGP neighbor is 5.5.5.5,  remote AS 65002, external link

  BGP version 4, remote router ID 6.6.6.6

  BGP state = Established, up for 00:19:25  àEBGP鄰居已建立

R3#sh ip bgp neighbors

BGP neighbor is 3.3.3.3,  remote AS 65001, external link

  BGP state = Established, up for 00:22:59  àEBGP鄰居已建立

步驟七:檢視bgp轉發表

R1#sh ip bgp

BGP table version is 5, local router ID is 2.2.2.2

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop        Metric LocPrf Weight Path

*> 2.2.2.0/24       0.0.0.0                 0         32768 i

*>i4.4.4.0/24       3.3.3.3                 0    100      0 i

*>i6.6.6.0/24       3.3.3.3                 0    100      0 65002 i

* i10.1.1.0/24      3.3.3.3                 0    100      0 i

*>                0.0.0.0                0         32768 i

R2#sh ip bgp

BGP table version is 5, local router ID is 4.4.4.4

   Network          Next Hop         Metric LocPrf Weight Path

*>i2.2.2.0/24       1.1.1.1                  0   100      0 i

*> 4.4.4.0/24       0.0.0.0                  0         32768 i

*> 6.6.6.0/24       5.5.5.5                  0             0 65002 i

* i10.1.1.0/24      1.1.1.1                  0    100      0 i

*>               0.0.0.0                  0         32768 i

R3#sh ip bgp

BGP table version is 5, local router ID is 6.6.6.6

*> 2.2.2.0/24       3.3.3.3                                0 65001 i

*> 4.4.4.0/24       3.3.3.3                  0             0 65001 i

*> 6.6.6.0/24       0.0.0.0                  0         32768 i

*> 10.1.1.0/24      3.3.3.3                  0             0 65001 i

步驟八:用ping指令測試連通性或用擴充ping指令

R1#ping  6.6.6.6

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 60/60/64 ms

R1#ping 4.4.4.4

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

R2#ping 2.2.2.2

R3#ping 2.2.2.2

Success rate is 100 percent (5/5), round-trip min/avg/max = 60/60/60 ms

r3#ping 4.4.4.4

步驟九:檢視配置

R1#sh run

hostname R1

!

interface Loopback0

 ip address 1.1.1.1 255.255.255.0

interface Loopback1

 ip address 2.2.2.2 255.255.255.0

interface Serial0

 ip address 10.1.1.1 255.255.255.0

 clockrate 64000

router eigrp 100

 network 1.1.1.0 0.0.0.255

 network 10.1.1.0 0.0.0.255

 no auto-summary

router bgp 65001

 no synchronization

network 2.2.2.0 mask 255.255.255.0

 network 10.1.1.0 mask 255.255.255.0

 neighbor 3.3.3.3 remote-as 65001

 neighbor 3.3.3.3 update-source Loopback0

end

R2#sh run

hostname R2

 ip address 3.3.3.3 255.255.255.0

 ip address 4.4.4.4 255.255.255.0

 ip address 20.1.1.1 255.255.255.0

interface Serial1

 ip address 10.1.1.2 255.255.255.0

 network 3.3.3.0 0.0.0.255

network 4.4.4.0 mask 255.255.255.0

 neighbor 1.1.1.1 remote-as 65001

 neighbor 1.1.1.1 update-source Loopback0

 neighbor 1.1.1.1 next-hop-self

 neighbor 5.5.5.5 remote-as 65002

 neighbor 5.5.5.5 ebgp-multihop 255

 neighbor 5.5.5.5 update-source Loopback0

ip route 5.5.5.0 255.255.255.0 20.1.1.2

R3#sh run

Hostname R3

 ip address 5.5.5.5 255.255.255.0

 ip address 6.6.6.6 255.255.255.0

 ip address 20.1.1.2 255.255.255.0

router bgp 65002

network 6.6.6.0 mask 255.255.255.0

 neighbor 3.3.3.3 ebgp-multihop 255

ip route 3.3.3.0 255.255.255.0 20.1.1.1

    本文轉自hexianguo 51CTO部落格,原文連結:http://blog.51cto.com/xghe110/89139,如需轉載請自行聯系原作者

繼續閱讀