天天看點

POJ - 2236-Wireless Network (并查集)

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 

1. "O p" (1 <= p <= N), which means repairing computer p. 

2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
      

Sample Output

FAIL
SUCCESS      

思路:建立一個數組把之前的資訊保留下來,去周遊,然後通過距離的判斷是否能進行連接配接,注意輸入既有整數,又有字元,故當成字元串輸入

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<cmath>

using namespace std;
int pre[1005];
int s[1005];
struct node
{
	double x,y;
}p[1005];
double dis(node a,node b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

int find(int x)
{
	if(x==pre[x])
	{
		return x;
	}
	else
	{
		return pre[x]=find(pre[x]);
	}
}
void merge(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		pre[fx]=fy;
	}
}
int sum=1;
int main()
{
	int N;
	double d;
	
	cin>>N>>d;
		for(int t=1;t<=N;t++)
		{
			scanf("%lf %lf",&p[t].x,&p[t].y);
		}
		for(int t=0;t<=N;t++)
		{
			pre[t]=t;
		}
		memset(s,0,sizeof(s));
		char c[2];
		int p1,q;
		while(scanf("%s",c)!=EOF)
		{
			if(c[0]=='O')
			{
				scanf("%d",&p1);
				for(int t=1;t<=sum;t++)
				{
					if(dis(p[s[t]],p[p1])<=d+1e-6)
					merge(s[t],p1);
				}
				s[sum++]=p1;
			}
			if(c[0]=='S')
			{
				scanf("%d%d",&p1,&q);
				if(find(p1)==find(q))
				{
					printf("SUCCESS\n");
				}
				else
				{
					printf("FAIL\n");
				}
			}
		}
	
	
	
	return 0;
}                

作者:李斌

繼續閱讀