天天看點

hdu2001

**

hdu2001:求兩點距離

**

Problem Description

輸入兩點坐标(X1,Y1),(X2,Y2),計算并輸出兩點間的距離。

Input

輸入資料有多組,每組占一行,由4個實數組成,分别表示x1,y1,x2,y2,資料之間用空格隔開。

Output

對于每組輸入資料,輸出一行,結果保留兩位小數。

Sample Input

0 0 0 1

0 1 1 0

Sample Output

1.00

1.41

思路:求兩點坐标距離就主要是利用數學公式并轉化為代碼

注意:要注意精度問題,防止出現精度流失,以及引用數學公式時要注意添加頭檔案。

#include <stdio.h>
#include <math.h>
void main()
{
	double x1,y1,x2,y2,m;
	printf("請輸入多個點的橫縱坐标:\n");
	while(scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2)!=EOF)
	{
		m=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
		printf("%.2lf\n",m);
	}
}