天天看點

2051Bitset

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 19403    Accepted Submission(s): 14612

Problem Description Give you a number on base ten,you should output it on base two.(0 < n < 1000)  

Input For each case there is a postive number n on base ten, end of file.  

Output For each case output a number on base two.  

Sample Input

1
2
3
        

Sample Output

1
10
11
        

 題目意思是把十進制數轉換成二進制數

#include<iostream>
#include<cstdio>
using namespace std;
int a[21];
int main(){
	int n;
	while(cin>>n){
		int i=0;
		while(n){
			a[i] = n%2;
			n /= 2;
			i++;
		}
		for(int j=i-1 ;j>=0 ;j--){
			cout<<a[j];
		}
		cout<<endl;
	}
	
	return 0;
}
           

繼續閱讀