天天看點

HDOJ Piggy-BankPiggy-Bank

Piggy-Bank

http://acm.hdu.edu.cn/showproblem.php?pid=1114

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3183    Accepted Submission(s): 1577

Problem Description Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
        

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
        

Source Central Europe 1999  

//這是完全背包,bag[j]表示存錢罐的容積為j時存錢的最小值

#include<iostream>

#include<cstring>

using namespace std;

const int INF=999999999;

int bag[10005],value[505],volume[505];

int main(){

    int t,V,N,e,f;

    scanf("%d",&t);

    while(t--){

         scanf("%d%d",&e,&f);

         V=f-e;

         for(int i=0;i<=V;i++)   //這題是求最小值,是以初始化為最大,若是求最大值則初始化為最小

              bag[i]=INF;

         bag[0]=0; //這步不要忘記哦

         scanf("%d",&N);

         for(int i=1;i<=N;i++)

              scanf("%d%d",&value[i],&volume[i]);

         for(int i=1;i<=N;i++)

               for(int v=volume[i];v<=V;v++)  //這裡和01背包順序是相反的

                    bag[v]=min(bag[v],bag[v-volume[i]]+value[i]);

         if(bag[V]==INF)

              printf("This is impossible.\n");

         else

              printf("The minimum amount of money in the piggy-bank is %d.\n",bag[V]);

    }

    //system("pause");

    return 0;

}

繼續閱讀