天天看點

PAT-A 1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, 

loading

 and 

being

 are stored as showed in Figure 1.

PAT-A 1032 Sharing (25 分)

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of 

i

 in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next
           

where

Address

 is the position of the node, 

Data

 is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and 

Next

 is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output 

-1

instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
           

Sample Output 1:

67890
           

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
           

Sample Output 2:

-1
           

思路:資料部分沒有用到,是以可以将每個節點儲存到map中,映射是從該節點位址到下一節點的位址。将兩個單詞的結點的位址依次入棧,再依次彈出,直到有一個棧為空或者彈出的值不等為止。輸出的時候注意,如果不是-1要使用"%05d"進行格式化。

#include <cstdio>
#include <map>
#include <stack>

using namespace std;

int main()
{
    int head1, head2, n;
    scanf("%d %d %d", &head1, &head2, &n);

    map<int, int> all;  // address -> next

    for(int i = 0; i < n; i++)
    {
        int address, next;
        char data;

        scanf("%d %c %d", &address, &data, &next);
        all.insert(make_pair(address, next));
    }

    stack<int> word1, word2;

    while(head1 != -1)
    {
        word1.push(head1);
        head1 = all[head1];
    }

    while(head2 != -1)
    {
        word2.push(head2);
        head2 = all[head2];
    }

    int result = -1;
    while(!word1.empty() && !word2.empty() && word1.top() == word2.top())
    {
        result = word1.top();
        word1.pop();
        word2.pop();
    }
    if(result == -1)
        printf("-1\n");
    else
        printf("%05d\n", result);
    return 0;
}