天天看點

1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
           

Sample Output:

3 2 1.5 1 2.9 0 3.2
           
  •  多項式的存儲不一定要用結構體,一種更簡便的方法是把多項式存儲在數組中,其中,數組下标為指數,數組内容為系數。
  • pat有關多項式的題目可能會故意設定系數為零這種測試資料,如果系數為零,這一項不能算作多項式中的一項。
#include<cstdio>
using namespace std;
double Poly[1010];//多項式數組
int main()
{
    int K1;
    scanf("%d", &K1);
    int ex;
    double co;
    for(int i = 1; i <= K1; i++)
    {
        scanf("%d%lf", &ex, &co);
        Poly[ex] += co;
    }
    int K2;
    scanf("%d", &K2);
    for(int j = 1; j <= K2; j++)
    {
        scanf("%d%lf", &ex, &co);
        Poly[ex] += co;//兩個多項式相加過程
    }
    int Count = 0;
    for(int n = 0; n < 1010; n++)
    {
        if(Poly[n] != 0)
            Count++;//統計多項式項數
    }
    printf("%d", Count);
    for(int m = 1009; m >= 0; m--)
    {
        if(Poly[m] != 0)
            printf(" %d %.1f", m, Poly[m]);//倒序輸出
    }
    return 0;
}