天天看點

uvaoj-1593:alignment of code

You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other tabular information and aligns each column on a fixed vertical position, while keeping the resulting code as short as possible, making sure that only whitespaces that are absolutely required stay in the code. So, that the first words on each line are printed at position p1 = 1; the second words on each line are printed at the minimal possible position p2, such that all first words end at or before position p2 - 2; the third words on each line are printed at the minimal possible position p3, such that all second words end at or before position p3 - 2, etc.

For the purpose of this problem, the code consists of multiple lines. Each line consists of one or more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all ASCII punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to 126 inclusive). Whitespace consists of space characters (ASCII code 32).

Input 

The input file contains one or more lines of the code up to the end of file. All lines (including the last one) are terminated by a standard end-of-line sequence in the file. Each line contains at least one word, each word is 1 to 80 characters long (inclusive). Words are separated by one or more spaces. Lines of the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters long. There are at most 1000 lines in the input file.

Output 

Write to the output file the reformatted, aligned code that consists of the same number of lines, with the same words in the same order, without trailing and leading spaces, separated by one or more spaces such that i-th word on each line starts at the same position pi.

Note for the Sample:

The `

uvaoj-1593:alignment of code

' character in the example below denotes a space character in the actual files (ASCII code 32).

Sample Input 

start:  integer;    // begins here
stop: integer; //  ends here  
 s:  string;   
c:   char; // temp
      

Sample Output 

start: integer; // begins here 
stop:  integer; // ends   here 
s:     string;
c:     char;    // temp      

題解:劉汝佳135頁練習題5-1;考察string和sstream之類的東西,一道模拟題;

題目的意思大概就是在每行輸入一定數量的字元串,字元串之間用空格隔開,然後讓每一列的字元串之間左對齊//幸好不是右對齊;

我的思路就是定義一個一維數組用來存string們,然後建立一個一維數組來存每一列字元串的字元數的最大值,然後直接列印就行了,需要注意的就是每一行最後一個單詞後邊沒有空格;

code:

#include <string>

#include <iostream>

#include <cstdio>

#include <vector>

#include <sstream>

#include <algorithm>

using namespace std;

const int maxn=105000;

int main()

{

    string s[maxn];

    string str;

    int numb[maxn]={0};

    int dig[maxn]={0};

    int cnt=0;

    int num=0;

    while(getline(cin,str))

    {

        stringstream ss(str);

        string stri;

        int num_col=0;

        while(ss >> stri)

        {

            s[cnt]=stri;

            int len=(int)stri.size();

            numb[num_col]=max(numb[num_col],len);

            num_col++;

            cnt++;

        }

        dig[num++]=num_col;

    }

    cnt=0;

    for(int i=0; i<num; i++)

    {

        for(int j=0; j<dig[i]; j++)

        {

            cout<<s[cnt];

            cnt++;

            if(j==dig[i]-1) break;

            int len=(int)s[cnt-1].size();

            for(int k=0; k<numb[j]-len+1; k++)

                cout<<' ';

        }

        cout<<endl;

    }

    return 0;

}

筆記:

一道簡單題被卡很久對我來說幾乎是家常便飯了,做出來以後感覺很簡單,沒做出來真的是虐心啊;

這道題首先是最後的細節,UVA經常因為空格來讓題目WA,這個要注意;

另外s.size()的時候需要強制轉換,看起來是個好習慣,記下來;

最主要的是string的意義,string是一個類似int的類型,而不是char s[100]這樣的字元型數組,string s[100]的意思就是一個一維數組;

關于string貼上連結:

string類型詳解;

http://blog.csdn.net/nefu2015214119/article/details/50631150;

給劉汝佳跪了,繼續去鑽研。。。