天天看點

HDU 1151 Air Raid【最小路徑覆寫】

Air Raid

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3866    Accepted Submission(s): 2556

Problem Description Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.

Input Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections

no_of_streets

S1 E1

S2 E2

......

Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.

Output The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.

Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3
        

Sample Output

2
1
        

Source Asia 2002, Dhaka (Bengal)

題目連結。

題目大意:

有一個城鎮,它的所有街道都是單行道,且每條街與兩個路口相連。同時保證街道不會形成回路。

求用最少的傘兵,去通路所有路口。傘兵可以通路任意路口,且最初位置也不受限。

解題思路:

求有向無環圖DAG的最小路徑覆寫。

将路口分為最初路口(所有)和到達路口(虛拟)。

最初路口也就是所有的路口。

到達路口設為虛設的路口。

将連通的兩個路口相連,求最大比對數(已有其他路口可達)。

最終可求得 傘兵數 = 路口數 - 最大比對數。

#include <cstdio>
#include <cstring>
const int maxn = 150;
bool road[maxn][maxn],vis[maxn];
int ins[maxn];	//路口标記
int n,m;		//n表示路口數,m表示街道數 
void init()
{
	int i,si,ei;
	memset(road,0,sizeof(road));
	memset(ins,0,sizeof(ins));
	for(i=0;i<m;++i)
	{
		scanf("%d%d",&si,&ei);
		road[si][ei]=true;		//構造DAG
	}
}
bool find(int p)
{
	int i,j;
	for(i=1;i<=n;++i)		//掃描虛拟路口
	{
		if(road[p][i]==true&&!vis[i])
		{
			vis[i]=true;
			if(ins[i]==0||find(ins[i]))
			{
				ins[i]=p;	//給未安排傘兵的 或可調整傘兵的路口 安排傘兵
				return true; 
			}
		}
	}
	return false;
}
int main()
{
	int t,i,count,ans;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		init();
		count=0;
		for(i=1;i<=n;++i)	//掃描路口 
		{
			memset(vis,0,sizeof(vis));
			if(find(i))
				count++;
		}
		ans = n	- count;	//路口數 - 最大比對數 
		printf("%d\n",ans);
	}
	return 0;
}
           

繼續閱讀