天天看點

Strategic game(POJ-1463)

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:

Strategic game(POJ-1463)

the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description:

  • the number of nodes
  • the description of each node in the following format

    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads

    or

    node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)      

Sample Output

1
2      

題意:給你一棵樹,樹上有子節點,問你最少需要多少個看守者可以看到所有的子節點

思路:dp方程的話,就是設一個dp[1000][2],當取本身節點的時候,就是dp[1000][1],取子節點的時候就是dp[1000][0];

剩下的話看代碼就好了,樹形DP入門題。

AC代碼:

#include <stdio.h>
#include <string.h>
#include <string>
#include <algorithm>
#include <iostream>
#include <vector>
#include <math.h>
const int maxx=10010;
using namespace std;
int vis[maxx],dp[maxx][2];
vector<int>son[maxx];
void dfs(int u)
{
    dp[u][1]=1;
    dp[u][0]=0;
    for(int i=0; i<son[u].size(); i++)
    {
        dfs(son[u][i]);
        dp[u][0]+=dp[son[u][i]][1];//目前節點放士兵的話,兒子節點就不放士兵
        dp[u][1]+=min(dp[son[u][i]][1],dp[son[u][i]][0]);//目前節點不放士兵的話,兒子節點可放可不放士兵
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(vis,-1,sizeof(vis));
        int fa,ch;
        for(int i=0; i<n; i++)
        {
            scanf("%d:(%d)",&fa,&ch);
            son[fa].clear();
            int cnt;
            for(int i=0; i<ch; i++)
            {
                scanf("%d",&cnt);
                son[fa].push_back(cnt);
                vis[cnt]=fa;
            }
        }
        int ans=0;//找根節點
        while(vis[ans]!=-1)
            ans=vis[ans];
        dfs(ans);
        printf("%d\n",min(dp[ans][1],dp[ans][0]));
    }
    return 0;
}