天天看點

杭電 3201Build a Fence

Build a Fence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 727    Accepted Submission(s): 564

Problem Description

杭電 3201Build a Fence

There is a wall in your backyard. It is so long that you can’t see its endpoints. You want to build a fence of length L such that the area enclosed between the wall and the fence is maximized. The fence can be of arbitrary shape, but only its two endpoints may touch the wall.

Input The input consists of several test cases.

For every test case, there is only one integer L (1<=L<=100), indicating the length of the fence.

The input ends with L=0.

Output For each test case, output one line containing the largest area. Your answer should be rounded to 2 digits after the decimal point.

Sample Input

1
100
0
        

Sample Output

0.16
1591.55      
#include<stdio.h>
#define pi 3.1415926
int main()
{  
	int L; 
	double s=0.0;  
	while(scanf("%d",&L),L)  
	{     
		s=(L*L)/(2*pi);     
		printf("%.2lf\n",s);   
	}  
	return 0;
}