天天看點

北大ACM poj2503 Babelfish

Babelfish

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay
      

Sample Output

cat
eh
loops
      

Hint

Huge input and output,scanf and printf are recommended.

//2503
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char chip[100001][15];
char bhip[100001][15];
int  idex[100001];
char w[15];
int L,yes;
int cmp(const void *a,const void *b)
{
	return strcmp(bhip[*(int *)a],bhip[*(int *)b]);
}

void main()
{
	int i,j,k,t;
	L=0;
	while(gets(w)&&w[0]!='\0')
	{
		sscanf(w,"%s %s",chip[L],bhip[L]);
		idex[L]=L;
		L++;
	}
	qsort(idex,L,sizeof(idex[0]),cmp);//快速排序

	while(gets(w))//二分查找
	{
		i=0;
		j=L-1;
		yes=0;
		while(i<=j)
		{
			k=(i+j)/2;
			t=strcmp(bhip[idex[k]],w);
			if(t>0)
			{
				j=k-1;
			}
			else if(t<0)
			{
				i=k+1;
			}
			else
			{
				yes=1;
				break;
			}

		}
		if(yes==1)
			printf("%s\n",chip[idex[k]]);
		else
		{
			printf("eh\n");
		}

	}
}