天天看點

POJ2096--Collecting Bugs--機率DP

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.

Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category.

Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version.

A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.

Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2      

Sample Output

3.0000

題意:可以直接把題目了解為有兩個桶,第一個桶裝n個球,第二個桶裝m個球。每次從第一個桶和第二個桶都拿出一個球染成黑色。問将所有球染成黑色需要多少次操作?

思路:E(aA+bB) = aE(A) + bE(B);

           好吧、、、趕腳我機率論白學了!!!

          每一次操作有4種情況,第一個桶拿出的是未染色,第二個染色。第一個染色,第二個未染色。都未染色或者都染色。

          用dp[i][j]表示第一個桶有i個染色了,第二個桶有j個染色了,将全部染色需要的操作數。

          顯然有dp[i][j] = p1*dp[i+1][j] + p2*dp[i][j+1] + p3*dp[i+1][j+1] + p4*dp[i][j] + 1;(對應上面4種可能)

          移項就可以得到dp[i][j] 和 其他三項的關系。

          然後反向循環遞推即可。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 1008
double dp[maxn][maxn];
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)==2)
	{
		dp[n][m] = 0;
		for(int i = m-1;i >= 0;i--)
			dp[n][i] = double(m)/(m-i) + dp[n][i+1];
		for(int i = n-1;i >= 0;i--)
			dp[i][m] = double(n)/(n-i) + dp[i+1][m];
		for(int i = n-1;i >= 0;i--)
			for(int j = m-1;j >= 0;j--)
				dp[i][j] = ((n-i)*j*dp[i+1][j] + i*(m-j)*dp[i][j+1] + (n-i)*(m-j)*dp[i+1][j+1] + n*m)/(n*m-i*j);
		printf("%.4lf\n",dp[0][0]);
	}
	return 0;
}