天天看點

hdu1312-Red and Black-dfs

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile

‘#’ - a red tile

‘@’ - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

           

Sample Output

45
59
6
13
           

題目大意:

hdu1312-Red and Black-dfs

解題思路:

水題!!!

不過此題有一個易錯點(坑點),點選這裡:

搜尋(bfs,dfs)易錯點-限制條件的選擇

代碼如下:

#include <iostream>
using namespace std;
const int N = 23;
char mp[N][N];
int sx, sy;
int num;
int n, m;

int dx[] = {0, 0, 1, -1}, dy[] = {1, -1, 0, 0};


void dfs(int x, int y) {
	num++;
	for (int i = 0; i < 4; i++) {
		int xx = x + dx[i], yy = y + dy[i];
		if (xx >= 0 && xx < n && yy >= 0 && yy < m && mp[xx][yy] == '.') {
			mp[xx][yy] = '#';
			dfs(xx, yy);
		}
	}
}

int main() {
	while (cin >> m >> n, n, m) {
		num = 0;
		for (int i = 0; i < n; i++) {
			cin >> mp[i];
			for (int j = 0; j < m; j++) {
				if (mp[i][j] == '@') {
					sx = i;
					sy = j;
				}
			}
		}
		dfs(sx, sy);
		cout << num << endl;
	}
	return 0;
}