天天看点

1132. Cut Integer (20) 除零

Cutting an integer means to cut a K digits long integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 x 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 20). Then N lines follow, each gives an integer Z (10<=Z<=231). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line "Yes" if it is such a number, or "No" if not.

Sample Input:

3
167334
2333
12345678
      

Sample Output:

Yes
No
No      
#include <iostream>
#include <string>
using namespace std;

int main() {
    int n;
    cin >> n;
    
    for (int i = 0; i < n; ++i){
        string s, s0, s1;
        cin >> s;
        s0 = s.substr(0, s.length()/2);
        s1 = s.substr(s.length()/2, s.length());
        long long a = stoi(s), b = stoi(s0), c = stoi(s1);
        if (b != 0 && c != 0) {
            if (a % (b * c) == 0){
                cout << "Yes" << endl;
                continue;
            }
        }
        cout << "No" << endl;
    }
    
    return 0;
}
           

继续阅读