天天看点

Hdoj 1233 还是畅通工程、kruskal入门题:【题解】

还是畅通工程

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。

当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最小的公路总长度。

Sample Input

3

1 2 1

1 3 2

2 3 4

4

1 2 1

1 3 4

1 4 1

2 3 3

2 4 2

3 4 5

Sample Output

3

5

注意:

数据范围对我来说常常是坑,估计不准确导致TLE;

推荐一篇kruskal算法我看了感觉比较清晰的博客:https://www.cnblogs.com/yoke/p/6697013.html

AC代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int M = 10005;	// 结点数 ******数据范围是大坑 
const int N = 10000+10; 		// 边数
int f[M], m, n, dis[M][M];
struct edge{
	int u, v, w;	
}e[N];		// 储存每个边的信息 
int get(int x){
	if(f[x] == x)	return x;
	return f[x] = get(f[x]);
}
bool unions(int x, int y){
	int rx = get(x), ry = get(y);
	if(rx != ry){		// 代表在不同的连通分量上 
		f[rx] = ry;
		return true;	// 传回1 
	} 
	return false;
}
bool cmp(edge a, edge b){
	return a.w < b.w;
}
int main(){
	while(scanf("%d", &n) != EOF){
		if(n == 0)	return 0;
		m = (n * (n - 1)) / 2;
		for(int i = 1; i <= m; i ++){
			f[i] = i;
			scanf("%d %d %d", &e[i].u, &e[i].v, &e[i].w);	
		}
		sort(e + 1, e + 1 + m, cmp);
		int ans = 0, num = 0;
		for(int i = 1; i <= m; i ++){
			if(unions(e[i].u, e[i].v)){
				ans += e[i].w;
				num ++;
			}
			if(num == n - 1)
				break;
		}
		printf("%d\n", ans);
	}
	return 0;
}