天天看点

http://acm.hdu.edu.cn/showproblem.php?pid=1711

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 1 3

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 2 1

Sample Output

6

-1

AC代码:

#include<iostream>
#include<string.h>
#define N 10001
#define M   1000001
using namespace std;
int a[M],b[N],next[N];
int n,m;
void KMP_next()
{   int i=1,j=0;
      next[0]=0;
    while(i<m)
    {  if(b[j]==b[i])
       {  next[i]=j+1;
          i++;j++;
       }
       else{ if(j>0) j=next[j-1];
             else next[i++]=0;
            }
       }
     }
    int main()
    {   int Case;
        cin>>Case;
          while(Case--)
          {  bool flag=false;
          memset(next,0,sizeof(next));
             cin>>n>>m;
             for(int i=0;i<n;i++)
                cin>>a[i];
                for(int i=0;i<m;i++)
                 cin>>b[i];
                  KMP_next();
                  int i=0,j=0;
                  while(i<n)
                  {  if(a[i]==b[j])
                     { if(j==m-1)  {flag=true;break;}
                        j++;i++;
                      }
                      else 
                     { if(j>0)  j=next[j-1];
                       else   i++;
                      }
                     }
                     if(flag) cout<<i-j+1<<endl;
                     else  cout<<"-1"<<endl;
                     } return 0;
        }
           

继续阅读