天天看点

http://acm.hdu.edu.cn/showproblem.php?pid=3342&&拓扑入门题Legal or Not

Legal or Not

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1743 Accepted Submission(s): 764

Problem Description ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

Input The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.

TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

Output For each test case, print in one line the judgement of the messy relationship.

If it is legal, output "YES", otherwise "NO".

Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0
        

Sample Output

YES
NO
  
  
   AC代码:
  
  
          
#include<iostream>
#include<string.h>
#include<cstdio>
#define N 105
#define CLR(arr,value) memset(arr,value,sizeof(arr))
using namespace std;
int head[N];
int num;
int visit[N];
int n;
typedef struct str
{
	int to;
	int next;
}Node;
Node node[2*N];
void init()
{
	CLR(head,-1);
	CLR(visit,0);
	num=0;
}
void add(int a,int b)
{
	node[num].to=b;
	node[num].next=head[a];
	head[a]=num++;
}
bool dfs(int v)
{
	visit[v]=-1;//表示正在访问,,正在栈中
	for(int i=head[v];i!=-1;i=node[i].next)
	{
		int u=node[i].to;
		if(visit[u]<0) return false;//存在负环,失败退出
		else if(!visit[u]&&!dfs(u)) return false;
	}
	visit[v]=1;//表示已经访问过,并且还递归访问过它的所有子孙
	return true;
}
bool toposort()//一个深搜的过程
{
	for(int i=0;i<n;++i)
		if(!visit[i])
		  if(!dfs(i)) return false;
	  return true;
}
int main()
{
	int m;
	while(~scanf("%d%d",&n,&m),n,m)
	{
		init();
		for(int i=0;i!=m;++i)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			add(a,b);
		}
		if(toposort()) printf("YES\n");
		else  printf("NO\n");
	}return 0;
}
           

继续阅读