天天看点

杭电oj~~1001Sum Problem

题目描述:

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 406139    Accepted Submission(s): 101994

Problem Description Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input The input will consist of a series of integers n, one integer per line.

Output For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input

1
100
        

Sample Output

1

5050
        

  java   AC 代码:

import java.util.Scanner;

public class Main{
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		while(in.hasNext())
		{
			long b = 0;
			long a = in.nextLong();
			for(long i=1;i<=a;i++)
			{
				b = b+i;
			}
			System.out.println(b);
			System.out.println();
		}
		
	}

}