天天看点

Starship Troopers (树形dp+背包)

You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

Input

The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.

Output

For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.

Sample Input

5 10
50 10
40 10
40 20
65 30
70 30
1 2
1 3
2 4
2 5
1 1
20 7
-1 -1      

Sample Output

50
7      

题目大概:

有一颗有根树,每个结点都有价值和敌人数,必须派士兵击败敌人,才能占领这个结点,取得价值。问k个士兵能获得的最大价值。

思路:

dp[i][j]指的是,第i个节点,派出j个士兵获得的价值。

遍历一遍数,回来的时候顺便做一下dp背包。利用子节点更新一下本结点的信息。

状态转移方程    dp[x][o]=max(dp[x][o],dp[x][o-j]+dp[son][j]);   到本节点,派出的o个士兵,可以在到达本节点之前派出,也可以在本结点之后派出。

发现还是利用结构体,存储树好,一般也不会超时。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

int n,p;
int dp[105][105];
int d[105],nao[105];
int head[105];
int minshu,no;
int ans;
struct shu
{
    int v;
    int next;
}tr[210];

void add(int q,int w)
{
    tr[ans].v=w;
    tr[ans].next=head[q];
    head[q]=ans++;

}

void dfs(int x,int pa)
{
    int bing=ceil((double)d[x]/20.0);
    for(int i=bing;i<=p;i++)dp[x][i]=nao[x];


    for(int i=head[x];i!=-1;i=tr[i].next)
    {
        int son=tr[i].v;
        if(son!=pa)
        {
            dfs(son,x);
            for(int o=p;o>=bing;o--)
            {
                for(int j=1;j<=o-bing;j++)
                {
                    dp[x][o]=max(dp[x][o],dp[x][o-j]+dp[son][j]);
                }
            }

        }
    }


}

int main()
{


   while(scanf("%d%d",&n,&p))
   {
       if(n==-1&&p==-1)break;
       memset(dp,0,sizeof(dp));
       memset(d,0,sizeof(d));
       memset(head,-1,sizeof(head));
       memset(nao,0,sizeof(nao));
       ans=0;
       for(int i=1;i<=n;i++)
       {
           scanf("%d%d",&d[i],&nao[i]);
       }

       for(int i=1;i<n;i++)
       {
           int q,w;
            scanf("%d%d",&q,&w);
            add(q,w);
            add(w,q);

       }
       if(p==0){printf("0\n");continue;}
       dfs(1,0);

       printf("%d\n",dp[1][p]);
   }
    return 0;
}
           

继续阅读