天天看点

杭电oj 1241最近在准备蓝桥杯 听了acm组的建议临时报佛脚准备学下dfs与bfs 然后看别人的博客里有提到一道入门的深搜题目 题目如下:

最近在准备蓝桥杯 听了acm组的建议临时报佛脚准备学下dfs与bfs 然后看别人的博客里有提到一道入门的深搜题目 题目如下:

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either

*', representing the absence of oil, or

@’, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
           

Sample Output

1

2

2

大概意思就是找有几个油田 @周围八个格子相连的@只算同一个油田。

感觉跟以前做的一道连连看的题目有点相似

这题就是通过一个递归完成 先遍历每次找到@的地方就对他进行搜索操作 搜索旁边是否有相连的@并且把走过的@变成*

代码如下:

#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<cstdio>

using namespace std;

char d[120][120];

int n,m;

void dfs(int x,int y)
{
	d[x][y]='*';
	int dx,dy;
	for(int i=-1;i<=1;i++){
		for(int k=-1;k<=1;k++){
			dx=x+i;
			dy=y+k;
			if(dx>=0&&dx<n&&dy>=0&&dy<m&&d[dx][dy]=='@'){
				dfs(dx,dy);
			}
		}
	}
}



int main()
{
	int ans=0,i,k;
	while(scanf("%d%d",&n,&m)!=EOF){
		ans=0;
		getchar();
		if(n==0&&m==0) break;
		for(i=0;i<n;i++){
			for(k=0;k<m;k++){
				scanf("%c",&d[i][k]);
			}
			getchar();
		}
		for(i=0;i<n;i++){
			for(k=0;k<m;k++){
				if(d[i][k]=='@'){
				dfs(i,k);
				ans++;
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}