天天看点

POJ3159 最大差距(差分约束系统) (K)

Candies

Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 18737 Accepted: 4930

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integersN and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 throughN. snoopy and flymouse were always numbered 1 and N. Then followM lines each holding three integers A, B and c in order, meaning that kidA believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4      

Sample Output

5      

Hint

32-bit signed integer type is capable of doing all arithmetic.

题意:给n个人派糖果,给出m组数据,每组数据包含A,B,c  三个数,意思是A的糖果数比B少的个数不多于c,即B的糖果数 - A的糖果数<= c 。最后求n 比 1 最多多多少糖果。

思路:这是一题典型的差分约束题。不妨将糖果数当作距离,把相差的最大糖果数看成有向边AB的权值,

我们得到 dis[B]-dis[A]<=w(A,B)。看到这里,我们联想到求最短路时的松弛技术,

即if(dis[B]>dis[A]+w(A,B), dis[B]=dis[A]+w(A,B)。

即是满足题中的条件dis[B]-dis[A]<=w(A,B),由于要使dis[B] 最大,

所以这题可以转化为最短路来求。

SPF的优先队列来做  如果用普通队列的话会TLE超时

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include<queue>
using namespace std;

#define inf 0x3f3f3f3f
#define maxn 30100
typedef pair<int,int> p;
int n,m;
int head[maxn];
int dis[maxn];
struct node
{
	int next,e,w;
}edge[150010];//存储边
bool inque[maxn];
void dijkstra()
{
	dis[1]=0;
	priority_queue<p,vector<p>,greater<p> >q;
	q.push(p(0,1));
	int first,second;
	memset(inque,false,sizeof inque);
	while(!q.empty())
	{
		p u=q.top();
		q.pop();
		int first=u.first;
        int last=u.second;
        inque[last]=false;
		for(int i=head[last];i!=-1;i=edge[i].next)
		{
			if(dis[edge[i].e]>dis[last]+edge[i].w)
			{
				dis[edge[i].e]=dis[last]+edge[i].w;
				if(!inque[edge[i].e])
				{inque[edge[i].e]=true;
					q.push(p(dis[edge[i].e],edge[i].e));
				}
			}
		}
	}
	printf("%d\n",dis[n]);
}
int main()
{
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++)//邻接表存储  初始化
	{
		head[i]=-1;
		dis[i]=inf;
	}
	int a,b,c;
	for(int i=0;i<m;i++)
	{
		scanf("%d%d%d",&a,&b,&c);
		edge[i].e=b;
		edge[i].w=c;
		edge[i].next=head[a];
		head[a]=i;
	}
	            
dijkstra();
           
}