天天看点

ZOJ Course Selection System DP

​​http://acm.zju.edu.cn/onlinejudge/showContestProblem.do?problemId=5565​​

Course Selection System

Time Limit: 1 Second      Memory Limit:

There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selects m courses x1, x2, ..., xm, then his comfort level of the semester can be defined as follows:

Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains a integer n (1 ≤ n

Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci ≤ 100).

It is guaranteed that the sum of all n

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each case, you should output one integer denoting the maximum comfort.

Sample Input

2
3
10 1
5 1
2 10
2
1 10
2 10      

Sample Output

191
0      

Hint

For the first case, Edward should select the first and second courses.

For the second case, Edward should select no courses.

​​Submit​​​    ​​Status​​

设sigma(H[i]) = a,sigma(c[i]) = b

那么原式 = a * (a - b) - b * b

对于固定b值,我们希望a值越大越好。

一开始的时候设dp[i][j][b]表示前i们科目,选了j们,产生的b值是b的时候,的最大a值。

然后发现这样会超时。观察到选了多少门我们是并不关心的。这样可以省掉500

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <assert.h>
#define IOS ios::sync_with_stdio(false)
using namespace std;
#define inf (0x3f3f3f3f)
typedef long long int LL;


#include <iostream>
#include <sstream>
#include <vector>
#include <set>
#include <map>
#include <queue>
#include <string>
#include <bitset>
const int maxn = 500 * 100 + 20;
int dp[maxn];
int h[maxn], c[maxn];
void work() {
    memset(dp, 0, sizeof dp);
    int n;
    scanf("%d", &n);
    int tot = 0;
    for (int i = 1; i <= n; ++i) {
        scanf("%d%d", &h[i], &c[i]);
        tot += c[i];
    }
    for (int i = 1; i <= n; ++i) {
        for (int j = tot; j >= c[i]; --j) {
            dp[j] = max(dp[j], dp[j - c[i]] + h[i]);
        }
    }
    LL ans = 0;
    for (int i = 1; i <= tot; ++i) {
        LL t = 1LL * dp[i] * dp[i] - 1LL * dp[i] * i - 1LL * i * i;
        ans = max(ans, t);
    }
    printf("%lld\n", ans);
}
int main() {
#ifdef local
    freopen("data.txt", "r", stdin);
//    freopen("data.txt", "w", stdout);
#endif
    int t;
    scanf("%d", &t);
    while (t--) work();
    return 0;
}