天天看点

PAT 甲级 1146  Topological Order

1146 Topological Order (25 point(s))

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

PAT 甲级 1146  Topological Order

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6      

Sample Output:

3 4      

经验总结:

AC代码

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn=1010;
int n,m,k,indegree[maxn]={0},tdegree[maxn],a,b;
vector<int> adj[maxn];

int main()
{
  scanf("%d%d",&n,&m);
  for(int i=0;i<m;++i)
  {
    scanf("%d%d",&a,&b);
    ++indegree[b];
    adj[a].push_back(b);
  }
  scanf("%d",&k);
  bool f=false;
  for(int i=0;i<k;++i)
  {
    for(int i=1;i<=n;++i)
      tdegree[i]=indegree[i];
    bool flag=false;
    for(int j=0;j<n;++j)
    {
      scanf("%d",&a);
      if(tdegree[a]!=0)
        flag=true;
      for(int x=0;x<adj[a].size();++x)
        --tdegree[adj[a][x]];
    }
    if(flag==true)
      if(f==false)
      {
        printf("%d",i);
        f=true;
      }
      else
        printf(" %d",i);
  }
  return 0;
}